Project

General

Profile

action #17212

test fails in textinfo on trying to tar changing files

Added by dimstar almost 6 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2017-02-20
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

The collection of log-files is a bit too fragile, as we do not take into account that the systems keeps on running, and especially on log-extraction the system might fail due to files changing underneath.

This is not a test that fails all the time, yet it does from time to time and it would be nice to address the issue

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-kde@64bit fails in
textinfo

Reproducible

Fails since (at least) Build 20170219 (current job)

Expected result

Last good: 20170218 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by okurz almost 6 years ago

  • Subject changed from test fails in textinfo to test fails in textinfo on trying to tar changing files
  • Status changed from New to Resolved
  • Assignee set to okurz

commit 7cd5331
Author: Oliver Kurz okurz@suse.de
Date: Tue Mar 28 08:15:26 2017 +0200

textinfo: Do not ignore unknown errors but only explicitly (#2636)

Followup to
https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/2622, fixes
https://openqa.opensuse.org/tests/377518#step/textinfo/4

Also available in: Atom PDF