Project

General

Profile

action #17204

[migration] migration on aarch64 in openQA

Added by mitiao over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
New test
Start date:
2016-11-09
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Difficulty:

Description

Implement migration on aarch64 in openQA


Subtasks

action #14720: [migration][sp3][aarch64] add offline migration scenarios SP2->SP3 for aarch64Resolvedmitiao


Related issues

Related to openQA Tests - action #19852: [migration][aarch64] workaround for default selected toolchain module by yast scc on sles12sp2 aarch64Resolved2017-06-15

Related to openQA Tests - action #20040: [migration][aarch64] offline migration on aarch64 fails in consoletest_finish_symResolved2017-06-26

Related to openQA Tests - action #20216: [migration][aarch64] Add Upgrade capability for offline migration on aarch64Resolved2017-07-03

Blocked by openQA Tests - action #11948: [tools][aarch64] can't boot pre-installed imageResolved2016-05-12

History

#1 Updated by okurz over 4 years ago

  • Related to action #11948: [tools][aarch64] can't boot pre-installed image added

#2 Updated by okurz over 4 years ago

  • Related to deleted (action #11948: [tools][aarch64] can't boot pre-installed image)

#3 Updated by okurz over 4 years ago

  • Blocked by action #11948: [tools][aarch64] can't boot pre-installed image added

#6 Updated by okurz over 4 years ago

  • Target version changed from Milestone 6 to Milestone 7

#7 Updated by okurz over 4 years ago

  • Category set to New test

#10 Updated by mitiao over 4 years ago

  • Status changed from New to In Progress

With the PR#2824 is merged, migration on aarch64 became possible now.
https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/2824

Just tried to created 1 SP2 image and boot it to perform online migration on aarch64.
This is just a TEST to see how it is going on aarch64, please see comment in:
https://progress.opensuse.org/issues/11948#note-53

#11 Updated by mitiao over 4 years ago

Created 12sp2 image failed on aarch64 worker due to issue poo#12250
https://openqa.suse.de/tests/940559

#12 Updated by okurz over 4 years ago

Please don't trigger jobs in the job groups of released products. You can move existing jobs to other groups or delete the group assignment, e.g. jobs/639172 put --json-data '{"group_id": 0}' to delete. Or use clone_job.pl … _GROUP=0 to clone but not show up the result in the group

#13 Updated by mitiao over 4 years ago

okurz wrote:

Please don't trigger jobs in the job groups of released products. You can move existing jobs to other groups or delete the group assignment, e.g. jobs/639172 put --json-data '{"group_id": 0}' to delete. Or use clone_job.pl … _GROUP=0 to clone but not show up the result in the group

oh, i cloned job without deleting group assignment, will append it in the case.

#14 Updated by mitiao over 4 years ago

Submitted a PR to try to avoid issue #12250 on sle12sp2 aarch64 image creation:
https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/3033

#15 Updated by mitiao over 4 years ago

mitiao wrote:

Submitted a PR to try to avoid issue #12250 on sle12sp2 aarch64 image creation:
https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/3033

PR merged, and sp2 image created successfully.
Working on migration part.

#16 Updated by mitiao over 4 years ago

Tried both online and offline migration for aarch64, issues raised up:

offline migration:
The toolchain module default selected by yast scc on sp2 aarch64
https://openqa.suse.de/tests/994496#step/patch_before_migration/21
this behaviour is not shown on sp3 aarch64, i suppose that is a bug, and asked whdu to ask yast or scc team

online migration:
https://openqa.suse.de/tests/994318
failed at first step, since aarch64 booting is quiet different with other archs, i will adapt it specifically for online migration on aarch64

#17 Updated by mitiao over 4 years ago

mitiao wrote:

online migration:
https://openqa.suse.de/tests/994318
failed at first step, since aarch64 booting is quiet different with other archs, i will adapt it specifically for online migration on aarch64

Submitted PR: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/3064

#18 Updated by mitiao over 4 years ago

mitiao wrote:

Tried both online and offline migration for aarch64, issues raised up:

offline migration:
The toolchain module default selected by yast scc on sp2 aarch64
https://openqa.suse.de/tests/994496#step/patch_before_migration/21
this behaviour is not shown on sp3 aarch64, i suppose that is a bug, and asked whdu to ask yast or scc team

According to bsc#1044234,the toolchain module default selected by yast scc on sp2 aarch64 is expected behaviour.
Opened a ticket to workaround it.

#19 Updated by mitiao over 4 years ago

  • Related to action #19852: [migration][aarch64] workaround for default selected toolchain module by yast scc on sles12sp2 aarch64 added

#20 Updated by mitiao over 4 years ago

mitiao wrote:

mitiao wrote:

online migration:
https://openqa.suse.de/tests/994318
failed at first step, since aarch64 booting is quiet different with other archs, i will adapt it specifically for online migration on aarch64

Submitted PR: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/3064

PR merged and verified on o.s.d."
https://openqa.suse.de/tests/1013861#step/bootloader_uefi/1

#21 Updated by mitiao over 4 years ago

  • Status changed from In Progress to Feedback

Added online and offline cases for aarch64 to Migration: Server job group.
See results in next run.

#22 Updated by mitiao over 4 years ago

online on aarch64 works well like this:
https://openqa.suse.de/tests/1017176

offline on aarch64 stopped at consoletest_finish_sym.pm by switching tty to x11, need more investigation on it.

#23 Updated by mitiao over 4 years ago

  • Related to action #20040: [migration][aarch64] offline migration on aarch64 fails in consoletest_finish_sym added

#24 Updated by mitiao over 4 years ago

mitiao wrote:

online on aarch64 works well like this:
https://openqa.suse.de/tests/1017176

offline on aarch64 stopped at consoletest_finish_sym.pm by switching tty to x11, need more investigation on it.

Investigation and resolving on https://progress.opensuse.org/issues/20040

#25 Updated by mitiao over 4 years ago

PR submitted for related poo#20040
and raised one more related poo#20216

#26 Updated by mitiao over 4 years ago

  • Related to action #20216: [migration][aarch64] Add Upgrade capability for offline migration on aarch64 added

#27 Updated by mitiao over 4 years ago

  • Status changed from Feedback to Resolved

All related issues have been resolved.
Offline migration on aarch64 works now.
Resolved.

Also available in: Atom PDF