Project

General

Profile

action #16996

enable openQA maintenance testing

Added by lnussel over 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
QA
Target version:
Start date:
2017-06-02
Due date:
2017-06-16
% Done:

100%

Estimated time:

Description

openQA and the bot needs to be set up to also test maintenance updates for the new release


Related issues

Copied from openSUSE Leap 42.2 Release - action #13880: enable openQA maintenance testingResolved2016-09-232016-10-07

Copied to openSUSE Leap 15.0 - action #25032: enable openQA maintenance testingResolved2018-04-012018-04-19

History

#1 Updated by lnussel over 3 years ago

  • Copied from action #13880: enable openQA maintenance testing added

#2 Updated by lnussel over 3 years ago

  • Category deleted (Release Engineering)
  • Assignee changed from lnussel to coolo

Coolo, could you take care of this please?

#3 Updated by coolo over 3 years ago

I will align with Andreas, but yes

#4 Updated by coolo over 3 years ago

It's enabled, but broken - the installation order changed

#5 Updated by coolo over 3 years ago

  • Assignee deleted (coolo)

I can't commit to do more than that

#6 Updated by coolo over 3 years ago

#7 Updated by lnussel over 3 years ago

  • Assignee set to okurz

So, qa needs to take care of this now? Oliver?

#8 Updated by okurz over 3 years ago

  • Status changed from New to In Progress

riafarov will take care for now. He's no member of this progress project so I will keep the ticket assigned to me for now. lnussel can you add him?

#9 Updated by lnussel over 3 years ago

  • Assignee changed from okurz to riafarov

#11 Updated by riafarov about 3 years ago

  • Status changed from In Progress to Feedback

#12 Updated by riafarov about 3 years ago

  • Assignee deleted (riafarov)

#13 Updated by lnussel about 3 years ago

  • Status changed from Feedback to Closed
  • % Done changed from 0 to 100

the referenced error looks like the btrfs ENOSPACE issue so closing. thanks!

#14 Updated by coolo about 3 years ago

  • Status changed from Closed to New

https://openqa.opensuse.org/tests/overview?distri=opensuse&version=42.3&build=%3A510912.xorg-x11-server.6997&groupid=48 - now that yast actually takes the update into consideration we need to fight random popups :(

#15 Updated by okurz about 3 years ago

  • Category set to QA
  • Status changed from New to In Progress
  • Assignee set to riafarov

this popup is something that is induced by the special maintenance update so we can just trust this key and go forward, right?

riafarov: You looked into this before. Would you like to give a hand again?

#16 Updated by coolo about 3 years ago

we actually have needles for import-untrusted-gpg-key-598D0E63B3FD7E48 - but we used to be able to assert_screen in addon_products. Now we get suprise popups :(

#17 Updated by lnussel about 3 years ago

Since this popup must appear when adding the addon repo a separate step with assert_screen could be introduced.

#18 Updated by riafarov about 3 years ago

I'll take care of it if it's not super urgent. Should be done by the end of the day.

#20 Updated by riafarov about 3 years ago

  • Status changed from In Progress to Feedback

#21 Updated by riafarov about 3 years ago

  • Status changed from Feedback to Resolved

Tests work fine (except firefox_audio). Let me know if I can help with anything else.

#22 Updated by lnussel about 3 years ago

  • Copied to action #25032: enable openQA maintenance testing added

Also available in: Atom PDF