Project

General

Profile

action #16604

[sle][functional][desktop]test fails in sshxterm - delays on typing commands in terminal

Added by qkzhu over 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Start date:
2017-02-09
Due date:
2017-11-08
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-12-SP3-Desktop-DVD-x86_64-allpatterns@64bit fails in
sshxterm

Reproducible

Fails since (at least) Build 0108 (current job)

Expected result

Last good: 0107 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #26852: [sle][functional][tools][BLOCKED][bsc#1041747] assert_script_run sometimes/randomly type a duplicate letter in the beginningResolved2017-10-192018-03-27

History

#1 Updated by asmorodskyi over 4 years ago

reproduces for Server functional tests - https://openqa.suse.de/tests/767907#step/sshxterm/4

#2 Updated by dgutu over 4 years ago

#5 Updated by dgutu over 4 years ago

  • Subject changed from test fails in sshxterm to test fails in sshxterm - delays on typing commands in terminal

A lot of tests are failing because suddenly the chars in the console are starting to be typed with some delay.

#6 Updated by okurz over 4 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: USBinstall@uefi
http://openqa.suse.de/tests/790200

#7 Updated by okurz over 4 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: USBinstall@uefi
http://openqa.suse.de/tests/790200

#8 Updated by okurz almost 4 years ago

  • Subject changed from test fails in sshxterm - delays on typing commands in terminal to [sle][functional][desktop]test fails in sshxterm - delays on typing commands in terminal
  • Target version set to Milestone 11

#9 Updated by okurz almost 4 years ago

  • Due date set to 2017-11-08

#10 Updated by okurz almost 4 years ago

  • Related to action #26852: [sle][functional][tools][BLOCKED][bsc#1041747] assert_script_run sometimes/randomly type a duplicate letter in the beginning added

#11 Updated by okurz almost 4 years ago

  • Status changed from New to Resolved
  • Assignee set to okurz

I assume commit 2e98c8c2
Author: Oliver Kurz okurz@suse.de
Date: Fri Oct 6 20:05:18 2017 +0200

Check target match with x11_start_program by default in all instances

As checking for a screen with "assert_screen" after "x11_start_program" is the
standard action and it allows to save time because there is a target to look
for this is now the default action saving quite some time for all X11 tests.

Exceptions can still be applied, for example by specifying "valid => 0" on the
call of "x11_start_program".

Validation runs:
* SLE 12 SP1 qam-gnome: http://lord.arch/tests/7609 glxgears failed
  because of differing no_wait, update after newest test
* openSUSE TW yast2_gui: http://lord.arch/tests/7608

should cover this

Also available in: Atom PDF