Project

General

Profile

action #16120

Can't load needles from needle editor

Added by coolo over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
Concrete Bugs
Target version:
Start date:
2017-01-20
Due date:
% Done:

90%

Estimated time:
Difficulty:

Description

All I get is

[Fri Jan 20 07:02:45 2017] [9996:debug] GET "/needles/sle/firefox_extensions-firefox-extensions-show_flag-20161122.png"
[Fri Jan 20 07:02:45 2017] [9996:debug] Routing to controller "OpenQA::WebAPI::Controller::File" and action "needle"
[Fri Jan 20 07:02:45 2017] [9996:debug] 403 Forbidden (0.003842s, 260.281/s)

(basically master as deployed on osd)

History

#1 Updated by mkittler over 5 years ago

Not sure how to reproduce it. So when I open the needle editor and use the combo box to select needles the error occurs?

Looks like a permission problem and hence packaging/deployment issue.

#2 Updated by coolo over 5 years ago

There is a warn in the code:

Jan 24 13:49:34 openqa openqa[11963]: /var/lib/openqa/share/tests/sle/products/sle/needles/firefox-gnomeshell-installed-20151026.json is not in a subdir of /var/lib/openqa/share/tests/sle-12-SP1 at /usr/share/openqa/script/../lib/OpenQA/WebAPI/Controller/File.pm line 47.

#3 Updated by coolo over 5 years ago

the problem seems to be that the absolute dir is compared - but towards the not expanded tests directory, which is a symlink to sle

#4 Updated by coolo over 5 years ago

The only reason I can think of why these symlinks exist is that they pointed to opensuse before - and were changed to sle only later. But having sle-$VERSION symlink to sle doesn't make sense :(

#5 Updated by coolo over 5 years ago

E.g. these make sense:

drwxr-xr-x 9 geekotest nogroup 4096 10. Jan 22:45 sle-11-SP3
lrwxrwxrwx 1 root      root      10 11. Dez 2014  sle-11-SP4-Alpha -> sle-11-SP3

But the needle in database will be sle-11-SP3 - and the tests will be SP4. So this will eat the needle permissions

#6 Updated by coolo over 5 years ago

#7 Updated by mkittler over 5 years ago

Seems like Oliver already tried to fix it some time ago: https://github.com/os-autoinst/openQA/commit/2797bcffa5e9681db44e9d1a67eb0759aa7e85f6
Maybe this fix never worked or further commits broke it again.

#8 Updated by coolo over 5 years ago

  • Status changed from New to In Progress
  • Assignee set to coolo
  • % Done changed from 0 to 90

this was fixed in #1196 - but it's not yet verified in production. I assign the verification to me

#9 Updated by coolo over 5 years ago

  • Status changed from In Progress to Closed

verified

Also available in: Atom PDF