Project

General

Profile

action #16110

action #13598: [sles][functional]Test module sles+extratests has inconsistent results

Network restart detection in yast2_lan_restart is not reliabe

Added by mkravec about 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2017-01-19
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

This assumption is not always true:

  1. assert_script_run '[ -s strace.log ]'; # strace.log size is greater than zero (network restarted)
  2. assert_script_run '[ ! -s strace.log ]'; # strace.log size is not greater than zero (network not restarted)

Sometimes network was not restarted but strace.log is not empty.

Observation

openQA test in scenario sle-12-SP3-Server-DVD-x86_64-sles+extratests@64bit fails in
yast2_lan_restart

Reproducible

Fails since (at least) Build 0051

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by dzedro almost 5 years ago

  • Status changed from New to In Progress
  • Assignee set to dzedro

#2 Updated by dzedro almost 5 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF