Project

General

Profile

Actions

action #160293

closed

wicked_basic_ref@ppc64le reliably fails when run on qa-power8

Added by dimstar about 1 month ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Regressions/Crashes
Target version:
Start date:
2024-05-13
Due date:
% Done:

0%

Estimated time:
Tags:

Description

https://openqa.opensuse.org/tests/4182272

The test reliably fails whenever qe-power8:X picks up this multi-machine job. Whenever it runs on kerosene-8, the test passes.

The failure logged on qa-power8:X is:

Reason: backend died: Open vSwitch command 'set_vlan' with arguments 'tap4 1' failed: 'tap4' is not connected to bridge 'br1' at /usr/lib/os-autoinst/backend/qemu.pm line 127.

This in turn sounds like a setup error on qe-power8

Actions #1

Updated by okurz about 1 month ago

  • Tags set to infra, o3
  • Category set to Regressions/Crashes
  • Priority changed from Normal to Urgent
  • Target version set to Ready
Actions #2

Updated by okurz about 1 month ago

  • Assignee set to mkittler
Actions #3

Updated by mkittler about 1 month ago

  • Status changed from New to In Progress
Actions #4

Updated by mkittler about 1 month ago

The bridge config misses most of the lines for the particular tap interfaces. I'll rerun the setup script. I have just updated the system to Leap 15.5 and it booted-up fine.

Actions #5

Updated by mkittler about 1 month ago

  • Status changed from In Progress to Feedback
  • Priority changed from Urgent to Normal

I fixed the repo setup (before one got the error File './repodata/4d67e25a5d565c99e8a34b2e195b204b2327122d7841cdf89c6a3ac46540dcf1-primary.xml.gz' not found on medium 'http://download.opensuse.org/repositories/devel:openQA/15.5').

I ran the MM setup script and the machine should be generally configured. However, I nevertheless removed the tap worker class because we already have kerosene.qe.nue2.suse.org in NUE-FC and must not schedule tap jobs on both machines. It would also not be the best idea to connect them because qapower8-3 in in PRG2.

Actions #6

Updated by okurz about 1 month ago

  • Status changed from Feedback to Resolved

sounds good, should suffice

Actions

Also available in: Atom PDF