Project

General

Profile

Actions

action #157540

closed

coordination #154777: [saga][epic] Shareable os-autoinst and test distribution plugins

coordination #108527: [epic] os-autoinst wheels for scalable code reuse of helper functions and segmented test distributions

[sporadic] ci openQA: t/33-developer_mode.t fails size:M

Added by tinita 3 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Regressions/Crashes
Target version:
Start date:
2024-03-19
Due date:
% Done:

0%

Estimated time:

Description

Observation

https://app.circleci.com/pipelines/github/os-autoinst/openQA/13196/workflows/ddb935c7-31dd-4beb-877c-25ef1e703b4d/jobs/123231

[14:03:42] t/33-developer_mode.t .. 17/?     # Unexpected Javascript console errors, waiting for connection opened: [
    #   {
    #     level     => "SEVERE",
    #     message   => "http://localhost:9526/asset/3906633cf0/ws_console.js 8 WebSocket connection to 'ws://localhost:9528/liveviewhandler/tests/1/developer/ws-proxy' failed: Error during WebSocket handshake: Unexpected response code: 302",
    #     source    => "network",
    #     timestamp => 1710857067816,
    #   },
    # ]

    #   Failed test 'No unexpected js warnings'
    #   at /home/squamata/project/t/lib/OpenQA/Test/FullstackUtils.pm line 123.
    # Looks like you failed 1 test of 9.
[14:03:42] t/33-developer_mode.t .. 20/? 

Suggestions

  • While investigating the code in parallel try to reproduce locally with coverage enabled and multiple runs to get a statistically significant result, e.g. make test KEEP_DB=1 RETRY=500 TESTS=t/33-developer.t and go for lunch or continue coding :)
  • If it's not reproducible consider the same with coverage enabled and/or in circleCI, e.g. a temporary branch in your github repo fork
  • Identify where in https://github.com/os-autoinst/openQA/blob/master/t/33-developer_mode.t the redirection "302" could happen
  • Even though the test is not technically a UI test in the t/ui/ folder it might still be necessary to apply UI test related synchronisation means to fix the sporadic failure as a selenium instance is used
  • Might be a similar issue: #102578
Actions #1

Updated by okurz 3 months ago

  • Category set to Regressions/Crashes
  • Target version set to Ready
  • Parent task set to #108527
Actions #2

Updated by okurz 3 months ago

  • Subject changed from [sporadic] ci openQA: t/33-developer_mode.t fails to [sporadic] ci openQA: t/33-developer_mode.t fails size:M
  • Description updated (diff)
  • Status changed from New to Workable
Actions #4

Updated by mkittler 3 months ago ยท Edited

  • Status changed from Workable to In Progress
  • Assignee set to mkittler

I'll have a look at it.

Note that the case mentioned by @okurz in the previous comment is a completely different failure:

    #   Failed test 'logged-out before logging in as Demo'
    #   at /usr/lib/perl5/vendor_perl/5.26.1/Test/Selenium/Remote/Driver.pm line 367.
    #          got: 'Logged in as Demo'
    #     expected: 'Login'
    # Looks like you failed 1 test of 9.
[14:33:00] t/33-developer_mode.t .. 20/?

It happened in the following context:

    ok 3 - No unexpected js warnings
    ok 4 - found connection reused at 370
    1..4
ok 19 - connect with 2 clients at the same time (use case: developer opens 2nd tab)
# Subtest: resume test execution and 2nd tab
[debug] client connected: Demo
[debug] [pid:1461] connecting to os-autoinst command server for job 1 at ws://127.0.0.1:20013/n7RknVAXStXCMG8W/ws
[debug] client disconnected: Demo
    not ok 1 - logged-out before logging in as Demo
    ok 2 - Demo logged-inDemo
Actions #5

Updated by mkittler 3 months ago

Actions #6

Updated by mkittler 3 months ago

  • Status changed from In Progress to Feedback
Actions #7

Updated by okurz 3 months ago

  • Priority changed from Urgent to High
Actions #8

Updated by mkittler 2 months ago

  • Status changed from Feedback to Resolved

I haven't seen this issue since my PRs were merged (despite many PRs created by dependabot) so I'm considering this ticket resolved.

Actions

Also available in: Atom PDF