Project

General

Profile

Actions

action #156016

closed

[openQA][sle-micro][virtualization] Test slem_virtualization@uefi with Default-encrypted image was not triggered correctly size:M

Added by waynechen55 about 2 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
Support
Target version:
Start date:
2024-02-26
Due date:
% Done:

0%

Estimated time:

Description

Observation

Test run slem_virtualization@uefi keeps failing due to missing passphrase.

I found there is no

_SECRET_AD_DOMAIN_PASSWORD  "[redacted]"

in vars.json

Steps to reproduce

  • Look up in vars.json of failed test run

Impact

Virtualization test run with encrypted image failed due to missing passphrase.

Problem

Missing setting

_SECRET_AD_DOMAIN_PASSWORD  "[redacted]"

in triggered test run.

Suggestions

  • Check how relevant test is triggered
  • Check any missing settings
  • Retrigger relevant test run

Workaround

n/a


Related issues 1 (0 open1 closed)

Related to openQA Project - action #104751: Extend "_SECRET_" variable handling to os-autoinst backend password variablesResolvedokurz2022-01-102022-01-24

Actions
Actions #1

Updated by okurz about 2 months ago

  • Category set to Regressions/Crashes
  • Assignee set to okurz
  • Target version set to Ready

Maybe I moved worker instances and forgot to move the according global variables

Actions #2

Updated by okurz about 2 months ago

  • Due date set to 2024-03-11
  • Category changed from Regressions/Crashes to Support
  • Status changed from New to Feedback

waynechen55 wrote:

Observation

Test run slem_virtualization@uefi keeps failing due to missing passphrase.

I found there is no

_SECRET_AD_DOMAIN_PASSWORD    "[redacted]"

in vars.json

AFAIK that is expected as anything with _SECRET shouldn't end up in vars.json

Steps to reproduce

  • Look up in vars.json of failed test run

Impact

Virtualization test run with encrypted image failed due to missing passphrase.

Problem

Missing setting

_SECRET_AD_DOMAIN_PASSWORD    "[redacted]"

in triggered test run.

I don't think this is stated correctly. Do you have a reference test that showed the existance of that setting?

https://gitlab.suse.de/openqa/salt-pillars-openqa/-/blob/master/openqa/workerconf.sls#L48 shows that the setting is applied on a global level to all workers. The referenced failure job https://openqa.suse.de/tests/13602228#step/firstrun/8 was running on worker29. I verified that this variable is also set on worker29 in the file /etc/openqa/workers.ini

Actions #3

Updated by waynechen55 about 2 months ago

okurz wrote in #note-2:

waynechen55 wrote:

Observation

Test run slem_virtualization@uefi keeps failing due to missing passphrase.

I found there is no

_SECRET_AD_DOMAIN_PASSWORD  "[redacted]"

in vars.json

AFAIK that is expected as anything with _SECRET shouldn't end up in vars.json

Steps to reproduce

  • Look up in vars.json of failed test run

Impact

Virtualization test run with encrypted image failed due to missing passphrase.

Problem

Missing setting

_SECRET_AD_DOMAIN_PASSWORD  "[redacted]"

in triggered test run.

I don't think this is stated correctly. Do you have a reference test that showed the existance of that setting?

https://gitlab.suse.de/openqa/salt-pillars-openqa/-/blob/master/openqa/workerconf.sls#L48 shows that the setting is applied on a global level to all workers. The referenced failure job https://openqa.suse.de/tests/13602228#step/firstrun/8 was running on worker29. I verified that this variable is also set on worker29 in the file /etc/openqa/workers.ini

This test run has

_SECRET_AD_DOMAIN_PASSWORD  "[redacted]"

https://openqa.suse.de/tests/13542739/file/vars.json

Actions #4

Updated by okurz about 2 months ago

Ok, so ... good again?

Actions #5

Updated by okurz about 2 months ago

  • Priority changed from Normal to Low
Actions #6

Updated by waynechen55 about 2 months ago

okurz wrote in #note-4:

Ok, so ... good again?

Seems it does not affect my test run. But this setting is still not there with newly triggered test run. Do not know why it is missing fro vars.json.

Actions #7

Updated by okurz about 2 months ago

  • Related to action #104751: Extend "_SECRET_" variable handling to os-autoinst backend password variables added
Actions #8

Updated by okurz about 2 months ago

waynechen55 wrote in #note-6:

okurz wrote in #note-4:

Ok, so ... good again?

Seems it does not affect my test run. But this setting is still not there with newly triggered test run. Do not know why it is missing fro vars.json.

The question is rather why the variables did show up in vars.json at all because since https://github.com/os-autoinst/os-autoinst/pull/1909 from 2022 the variables starting with _SECRET_ should not show up in vars.json at all.

With that are you ok to accept the current behaviour as-is and we resolve this ticket?

Actions #9

Updated by livdywan about 2 months ago

  • Subject changed from [openQA][sle-micro][virtualization] Test slem_virtualization@uefi with Default-encrypted image was not triggered correctly to [openQA][sle-micro][virtualization] Test slem_virtualization@uefi with Default-encrypted image was not triggered correctly size:M
Actions #10

Updated by okurz about 1 month ago

  • Due date deleted (2024-03-11)
  • Status changed from Feedback to Resolved

No response, assuming ok.

Actions

Also available in: Atom PDF