Project

General

Profile

action #15586

Tar fails because file changed during archive creation

Added by mkravec about 5 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2016-12-20
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

tar: /var/log/messages: file changed as we read id

Observation

openQA test in scenario sle-12-SP3-Server-DVD-x86_64-migration_offline_sle12sp1_allpatterns@64bit fails in
textinfo

Reproducible

Fails since (at least) Build 0195 (current job)

Expected result

Last good: 0194 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by mkravec about 5 years ago

  • Priority changed from Normal to Low

Test failed only once with this problem, lowering priority

#3 Updated by okurz over 4 years ago

  • Status changed from New to In Progress

https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/2657 should fix that for all classes that use y2logstep. If there are any modules using save_y2log manually I suggest to use the same approach, e.g. same baseclass assuming it is about save_y2log as well.

#4 Updated by okurz about 4 years ago

  • Status changed from In Progress to Resolved
  • Assignee set to okurz

seems that did it

Also available in: Atom PDF