Project

General

Profile

Actions

action #155659

closed

[openQA][infra][sut] Failed to establish connnection to ix64ph1075-sp.qe.nue2.suse.org

Added by waynechen55 about 2 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Regressions/Crashes
Target version:
Start date:
2024-02-20
Due date:
% Done:

0%

Estimated time:
Tags:

Description

Observation

Can not establish ipmi sol connnection to ix64ph1075-sp.qe.nue2.suse.org

10:~ # ipmitool -I lanplus -H ix64ph1075-sp.qe.nue2.suse.org -U admin -P xxxxx chassis power status
Error: Unable to establish IPMI v2 / RMCP+ session
10:~ # ipmitool -I lanplus -H ix64ph1075-sp.qe.nue2.suse.org -U admin -P xxxxx sol deactivate
Error: Unable to establish IPMI v2 / RMCP+ session
10:~ # ping -c5 ix64ph1075-sp.qe.nue2.suse.org
PING ix64ph1075-sp.qe.nue2.suse.org (10.168.192.204) 56(84) bytes of data.
64 bytes from ix64ph1075-sp.qe.nue2.suse.org (10.168.192.204): icmp_seq=1 ttl=60 time=253 ms
64 bytes from ix64ph1075-sp.qe.nue2.suse.org (10.168.192.204): icmp_seq=2 ttl=60 time=253 ms
64 bytes from ix64ph1075-sp.qe.nue2.suse.org (10.168.192.204): icmp_seq=3 ttl=60 time=252 ms
64 bytes from ix64ph1075-sp.qe.nue2.suse.org (10.168.192.204): icmp_seq=4 ttl=60 time=252 ms
64 bytes from ix64ph1075-sp.qe.nue2.suse.org (10.168.192.204): icmp_seq=5 ttl=60 time=252 ms

--- ix64ph1075-sp.qe.nue2.suse.org ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 4005ms
rtt min/avg/max/mdev = 251.921/252.314/252.797/0.371 ms

Steps to reproduce

  • Use ipmitool to do operation

Impact

Test run keeps failing, for example, this one.

Problem

Looks like something wrong with management unit

Suggestions

  • Check management unit state
  • Check error/warning report from management unit
  • Check management unit configuration
  • Check ipmi sol is enabled

Workaround

n/a


Related issues 2 (0 open2 closed)

Related to openQA Infrastructure - action #150938: [openQA][sut][ipmi] No ipmi sol output with ix64ph1075 size:MResolvednicksinger2023-11-16

Actions
Related to openQA Infrastructure - action #157834: [openQA][ipmi] IPMI backend machines in NUE2 can not be reached auto_review:"Reason: backend died: ipmitool.*Address lookup for.*qe.nue2.suse.org":retryResolvedokurz2024-03-25

Actions
Actions #1

Updated by okurz about 2 months ago

  • Tags set to infra
  • Category set to Regressions/Crashes
  • Target version set to Ready
Actions #2

Updated by okurz about 2 months ago

  • Related to action #150938: [openQA][sut][ipmi] No ipmi sol output with ix64ph1075 size:M added
Actions #3

Updated by okurz about 2 months ago

  • Status changed from New to In Progress
  • Assignee set to okurz
Actions #4

Updated by okurz about 2 months ago

As part of #150938 credentials were reset. Fixed now with

ipmitool -C3 -H ix64ph1075-sp.qe.nue2.suse.org -U ADMIN -P … user set name 3 admin
ipmitool -C3 -H ix64ph1075-sp.qe.nue2.suse.org -U ADMIN -P … user set password 3 '…'
ipmitool -C3 -H ix64ph1075-sp.qe.nue2.suse.org -U ADMIN -P … channel setaccess 1 3 link=on ipmi=on callin=on privilege=4
ipmitool -C3 -H ix64ph1075-sp.qe.nue2.suse.org -U ADMIN -P … user enable 3

Restarted test
https://openqa.suse.de/tests/13554041

Actions #5

Updated by okurz about 2 months ago

  • Status changed from In Progress to Resolved
Actions #7

Updated by okurz 25 days ago

  • Related to action #157834: [openQA][ipmi] IPMI backend machines in NUE2 can not be reached auto_review:"Reason: backend died: ipmitool.*Address lookup for.*qe.nue2.suse.org":retry added
Actions

Also available in: Atom PDF