Project

General

Profile

Actions

tickets #153199

closed

mailman does not start - the 'flufl.lock>=5.1' distribution was not found and is required by mailman

Added by pjessen about 2 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Mailing lists
Target version:
-
Start date:
2024-01-08
Due date:
% Done:

0%

Estimated time:

Description

When trying to start mailman:

2024-01-08T07:07:54.439017+00:00 mailman3 mailman[10848]: Traceback (most recent call last):
2024-01-08T07:07:54.439606+00:00 mailman3 mailman[10848]:   File "/usr/bin/mailman", line 33, in <module>
2024-01-08T07:07:54.439776+00:00 mailman3 mailman[10848]:     sys.exit(load_entry_point('mailman==3.3.9', 'console_scripts', 'mailman')())
2024-01-08T07:07:54.439940+00:00 mailman3 mailman[10848]:              ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
2024-01-08T07:07:54.441330+00:00 mailman3 mailman[10848]:   File "/usr/lib/python3.11/site-packages/click/core.py", line 1157, in __call__
2024-01-08T07:07:54.441459+00:00 mailman3 mailman[10848]:     return self.main(*args, **kwargs)
2024-01-08T07:07:54.441568+00:00 mailman3 mailman[10848]:            ^^^^^^^^^^^^^^^^^^^^^^^^^^
2024-01-08T07:07:54.441612+00:00 mailman3 mailman[10848]:   File "/usr/lib/python3.11/site-packages/click/core.py", line 1077, in main
2024-01-08T07:07:54.441713+00:00 mailman3 mailman[10848]:     with self.make_context(prog_name, args, **extra) as ctx:
2024-01-08T07:07:54.441740+00:00 mailman3 mailman[10848]:          ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
2024-01-08T07:07:54.441764+00:00 mailman3 mailman[10848]:   File "/usr/lib/python3.11/site-packages/click/core.py", line 943, in make_context
2024-01-08T07:07:54.441788+00:00 mailman3 mailman[10848]:     self.parse_args(ctx, args)
2024-01-08T07:07:54.441815+00:00 mailman3 mailman[10848]:   File "/usr/lib/python3.11/site-packages/click/core.py", line 1644, in parse_args
2024-01-08T07:07:54.441839+00:00 mailman3 mailman[10848]:     rest = super().parse_args(ctx, args)
2024-01-08T07:07:54.441863+00:00 mailman3 mailman[10848]:            ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
2024-01-08T07:07:54.441900+00:00 mailman3 mailman[10848]:   File "/usr/lib/python3.11/site-packages/click/core.py", line 1408, in parse_args
2024-01-08T07:07:54.441924+00:00 mailman3 mailman[10848]:     value, args = param.handle_parse_result(ctx, opts, args)
2024-01-08T07:07:54.441947+00:00 mailman3 mailman[10848]:                   ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
2024-01-08T07:07:54.441971+00:00 mailman3 mailman[10848]:   File "/usr/lib/python3.11/site-packages/click/core.py", line 2400, in handle_parse_result
2024-01-08T07:07:54.442011+00:00 mailman3 mailman[10848]:     value = self.process_value(ctx, value)
2024-01-08T07:07:54.442036+00:00 mailman3 mailman[10848]:             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
2024-01-08T07:07:54.442075+00:00 mailman3 mailman[10848]:   File "/usr/lib/python3.11/site-packages/click/core.py", line 2362, in process_value
2024-01-08T07:07:54.442100+00:00 mailman3 mailman[10848]:     value = self.callback(ctx, self, value)
2024-01-08T07:07:54.442123+00:00 mailman3 mailman[10848]:             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
2024-01-08T07:07:54.442156+00:00 mailman3 mailman[10848]:   File "/usr/lib/python3.11/site-packages/mailman/bin/mailman.py", line 95, in initialize_config
2024-01-08T07:07:54.442180+00:00 mailman3 mailman[10848]:     initialize(value)
2024-01-08T07:07:54.442211+00:00 mailman3 mailman[10848]:   File "/usr/lib/python3.11/site-packages/mailman/core/initialize.py", line 229, in initialize
2024-01-08T07:07:54.442236+00:00 mailman3 mailman[10848]:     initialize_2(propagate_logs=propagate_logs)
2024-01-08T07:07:54.442264+00:00 mailman3 mailman[10848]:   File "/usr/lib/python3.11/site-packages/mailman/core/initialize.py", line 198, in initialize_2
2024-01-08T07:07:54.442294+00:00 mailman3 mailman[10848]:     initialize_pipelines()
2024-01-08T07:07:54.442314+00:00 mailman3 mailman[10848]:   File "/usr/lib/python3.11/site-packages/mailman/core/pipelines.py", line 73, in initialize
2024-01-08T07:07:54.442334+00:00 mailman3 mailman[10848]:     add_components('handlers', IHandler, config.handlers)
2024-01-08T07:07:54.442354+00:00 mailman3 mailman[10848]:   File "/usr/lib/python3.11/site-packages/mailman/utilities/modules.py", line 218, in add_components
2024-01-08T07:07:54.442379+00:00 mailman3 mailman[10848]:     for component_class in find_pluggable_components(subpackage, interface):
2024-01-08T07:07:54.442402+00:00 mailman3 mailman[10848]:   File "/usr/lib/python3.11/site-packages/mailman/utilities/modules.py", line 177, in find_pluggable_components
2024-01-08T07:07:54.442422+00:00 mailman3 mailman[10848]:     yield from find_components('mailman.' + subpackage, interface)
2024-01-08T07:07:54.442441+00:00 mailman3 mailman[10848]:   File "/usr/lib/python3.11/site-packages/mailman/utilities/modules.py", line 150, in find_components
2024-01-08T07:07:54.442472+00:00 mailman3 mailman[10848]:     module = import_module(module_name)
2024-01-08T07:07:54.442492+00:00 mailman3 mailman[10848]:              ^^^^^^^^^^^^^^^^^^^^^^^^^^
2024-01-08T07:07:54.442512+00:00 mailman3 mailman[10848]:   File "/usr/lib64/python3.11/importlib/__init__.py", line 126, in import_module
2024-01-08T07:07:54.442537+00:00 mailman3 mailman[10848]:     return _bootstrap._gcd_import(name[level:], package, level)
2024-01-08T07:07:54.442560+00:00 mailman3 mailman[10848]:            ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
2024-01-08T07:07:54.442580+00:00 mailman3 mailman[10848]:   File "<frozen importlib._bootstrap>", line 1204, in _gcd_import
2024-01-08T07:07:54.442600+00:00 mailman3 mailman[10848]:   File "<frozen importlib._bootstrap>", line 1176, in _find_and_load
2024-01-08T07:07:54.442620+00:00 mailman3 mailman[10848]:   File "<frozen importlib._bootstrap>", line 1147, in _find_and_load_unlocked
2024-01-08T07:07:54.442640+00:00 mailman3 mailman[10848]:   File "<frozen importlib._bootstrap>", line 690, in _load_unlocked
2024-01-08T07:07:54.442660+00:00 mailman3 mailman[10848]:   File "<frozen importlib._bootstrap_external>", line 940, in exec_module
2024-01-08T07:07:54.442679+00:00 mailman3 mailman[10848]:   File "<frozen importlib._bootstrap>", line 241, in _call_with_frames_removed
2024-01-08T07:07:54.442706+00:00 mailman3 mailman[10848]:   File "/usr/lib/python3.11/site-packages/mailman/handlers/validate_authenticity.py", line 23, in <module>
2024-01-08T07:07:54.442726+00:00 mailman3 mailman[10848]:     from authheaders import authenticate_message
2024-01-08T07:07:54.442764+00:00 mailman3 mailman[10848]:   File "/usr/lib/python3.11/site-packages/authheaders/__init__.py", line 25, in <module>
2024-01-08T07:07:54.442796+00:00 mailman3 mailman[10848]:     from authheaders.dmarc_lookup import dns_query, receiver_record, receiver_record_walk, get_org_domain
2024-01-08T07:07:54.442819+00:00 mailman3 mailman[10848]:   File "/usr/lib/python3.11/site-packages/authheaders/dmarc_lookup.py", line 22, in <module>
2024-01-08T07:07:54.442843+00:00 mailman3 mailman[10848]:     from pkg_resources import resource_filename  # Part of setuptools
2024-01-08T07:07:54.442867+00:00 mailman3 mailman[10848]:     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
2024-01-08T07:07:54.442897+00:00 mailman3 mailman[10848]:   File "/usr/lib/python3.11/site-packages/pkg_resources/__init__.py", line 3324, in <module>
2024-01-08T07:07:54.445029+00:00 mailman3 mailman[10848]:     @_call_aside
2024-01-08T07:07:54.445066+00:00 mailman3 mailman[10848]:      ^^^^^^^^^^^
2024-01-08T07:07:54.445088+00:00 mailman3 mailman[10848]:   File "/usr/lib/python3.11/site-packages/pkg_resources/__init__.py", line 3299, in _call_aside
2024-01-08T07:07:54.445108+00:00 mailman3 mailman[10848]:     f(*args, **kwargs)
2024-01-08T07:07:54.445148+00:00 mailman3 mailman[10848]:   File "/usr/lib/python3.11/site-packages/pkg_resources/__init__.py", line 3337, in _initialize_master_working_set
2024-01-08T07:07:54.445175+00:00 mailman3 mailman[10848]:     working_set = WorkingSet._build_master()
2024-01-08T07:07:54.445195+00:00 mailman3 mailman[10848]:                   ^^^^^^^^^^^^^^^^^^^^^^^^^^
2024-01-08T07:07:54.445215+00:00 mailman3 mailman[10848]:   File "/usr/lib/python3.11/site-packages/pkg_resources/__init__.py", line 631, in _build_master
2024-01-08T07:07:54.445255+00:00 mailman3 mailman[10848]:     ws.require(__requires__)
2024-01-08T07:07:54.445275+00:00 mailman3 mailman[10848]:   File "/usr/lib/python3.11/site-packages/pkg_resources/__init__.py", line 968, in require
2024-01-08T07:07:54.445294+00:00 mailman3 mailman[10848]:     needed = self.resolve(parse_requirements(requirements))
2024-01-08T07:07:54.445313+00:00 mailman3 mailman[10848]:              ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
2024-01-08T07:07:54.445333+00:00 mailman3 mailman[10848]:   File "/usr/lib/python3.11/site-packages/pkg_resources/__init__.py", line 829, in resolve
2024-01-08T07:07:54.445353+00:00 mailman3 mailman[10848]:     dist = self._resolve_dist(
2024-01-08T07:07:54.445552+00:00 mailman3 mailman[10848]:            ^^^^^^^^^^^^^^^^^^^
2024-01-08T07:07:54.445570+00:00 mailman3 mailman[10848]:   File "/usr/lib/python3.11/site-packages/pkg_resources/__init__.py", line 870, in _resolve_dist
2024-01-08T07:07:54.445588+00:00 mailman3 mailman[10848]:     raise DistributionNotFound(req, requirers)
2024-01-08T07:07:54.445607+00:00 mailman3 mailman[10848]: pkg_resources.DistributionNotFound: The 'flufl.lock>=5.1' distribution was not found and is required by mailman

Related issues 1 (0 open1 closed)

Blocks openSUSE admin - tickets #153271: mailman webui errorResolvedcrameleon2024-01-09

Actions
Actions #1

Updated by pjessen about 2 months ago

  • Private changed from Yes to No

I presume this was caused by the regular zypper dup :

2024-01-08 02:01:26 <1> mailman3(25423) [zypper] main.cc(main):115 ===== 'zypper' 'dup' '-y' '--auto-agree-with-product-licenses' =====
Actions #2

Updated by hellcp about 2 months ago

I guess it was caused by update from 7 to 8 for some reason? https://build.opensuse.org/package/rdiff/openSUSE:Factory/python-flufl.lock?linkrev=base&rev=9. I guess we just need a branch of 7 in openSUSE:infrastructure:mailman then

Actions #3

Updated by crameleon about 2 months ago

This sounds like a packaging bug in Factory. It would be good to resolve it for everyone.

Actions #4

Updated by crameleon about 2 months ago · Edited

Upon chatting with others, there already is an upstream patch for a similar module made by one of the package maintainers:
https://github.com/ValiMail/authentication-headers/pull/28

And the problem seems to break other Python modules, such as Mailman, as well.

Actions #6

Updated by pjessen about 2 months ago

Actions #7

Updated by crameleon about 2 months ago

  • Status changed from New to In Progress
  • Assignee set to crameleon

The patch for authheaders was now merged to Factory: https://build.opensuse.org/request/show/1137568.

Actions #8

Updated by crameleon about 2 months ago

Upgraded and Mailman starts again, however Mailman web is still causing issues, now with Haystack:

Jan 09 13:14:51 mailman3 mailman-web[24856]:   File "/usr/lib/python3.11/site-packages/haystack/__init__.py", line 4, in <module>
Jan 09 13:14:51 mailman3 mailman-web[24856]:     from pkg_resources import DistributionNotFound, get_distribution, parse_version
Jan 09 13:14:51 mailman3 mailman-web[24856]:   File "/usr/lib/python3.11/site-packages/pkg_resources/__init__.py", line 3324, in <module>
Jan 09 13:14:51 mailman3 mailman-web[24856]:     @_call_aside
Jan 09 13:14:51 mailman3 mailman-web[24856]:      ^^^^^^^^^^^
Jan 09 13:14:51 mailman3 mailman-web[24856]:   File "/usr/lib/python3.11/site-packages/pkg_resources/__init__.py", line 3299, in _call_a>
Jan 09 13:14:51 mailman3 mailman-web[24856]:     f(*args, **kwargs)
Jan 09 13:14:51 mailman3 mailman-web[24856]:   File "/usr/lib/python3.11/site-packages/pkg_resources/__init__.py", line 3337, in _initia>
Jan 09 13:14:51 mailman3 mailman-web[24856]:     working_set = WorkingSet._build_master()
Jan 09 13:14:51 mailman3 mailman-web[24856]:                   ^^^^^^^^^^^^^^^^^^^^^^^^^^
Jan 09 13:14:51 mailman3 mailman-web[24856]:   File "/usr/lib/python3.11/site-packages/pkg_resources/__init__.py", line 631, in _build_m>
Jan 09 13:14:51 mailman3 mailman-web[24856]:     ws.require(__requires__)
Jan 09 13:14:51 mailman3 mailman-web[24856]:   File "/usr/lib/python3.11/site-packages/pkg_resources/__init__.py", line 968, in require
Jan 09 13:14:51 mailman3 mailman-web[24856]:     needed = self.resolve(parse_requirements(requirements))
Jan 09 13:14:51 mailman3 mailman-web[24856]:              ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
Jan 09 13:14:51 mailman3 mailman-web[24856]:   File "/usr/lib/python3.11/site-packages/pkg_resources/__init__.py", line 829, in resolve
Jan 09 13:14:51 mailman3 mailman-web[24856]:     dist = self._resolve_dist(
Jan 09 13:14:51 mailman3 mailman-web[24856]:            ^^^^^^^^^^^^^^^^^^^
Jan 09 13:14:51 mailman3 mailman-web[24856]:   File "/usr/lib/python3.11/site-packages/pkg_resources/__init__.py", line 870, in _resolve>
Jan 09 13:14:51 mailman3 mailman-web[24856]:     raise DistributionNotFound(req, requirers)
Actions #9

Updated by gladiac about 2 months ago

crameleon wrote in #note-8:

Upgraded and Mailman starts again, however Mailman web is still causing issues, now with Haystack:

Jan 09 13:14:51 mailman3 mailman-web[24856]:   File "/usr/lib/python3.11/site-packages/haystack/__init__.py", line 4, in <module>
Jan 09 13:14:51 mailman3 mailman-web[24856]:     from pkg_resources import DistributionNotFound, get_distribution, parse_version
Jan 09 13:14:51 mailman3 mailman-web[24856]:   File "/usr/lib/python3.11/site-packages/pkg_resources/__init__.py", line 3324, in <module>
Jan 09 13:14:51 mailman3 mailman-web[24856]:     @_call_aside
Jan 09 13:14:51 mailman3 mailman-web[24856]:      ^^^^^^^^^^^
Jan 09 13:14:51 mailman3 mailman-web[24856]:   File "/usr/lib/python3.11/site-packages/pkg_resources/__init__.py", line 3299, in _call_a>
Jan 09 13:14:51 mailman3 mailman-web[24856]:     f(*args, **kwargs)
Jan 09 13:14:51 mailman3 mailman-web[24856]:   File "/usr/lib/python3.11/site-packages/pkg_resources/__init__.py", line 3337, in _initia>
Jan 09 13:14:51 mailman3 mailman-web[24856]:     working_set = WorkingSet._build_master()
Jan 09 13:14:51 mailman3 mailman-web[24856]:                   ^^^^^^^^^^^^^^^^^^^^^^^^^^
Jan 09 13:14:51 mailman3 mailman-web[24856]:   File "/usr/lib/python3.11/site-packages/pkg_resources/__init__.py", line 631, in _build_m>
Jan 09 13:14:51 mailman3 mailman-web[24856]:     ws.require(__requires__)
Jan 09 13:14:51 mailman3 mailman-web[24856]:   File "/usr/lib/python3.11/site-packages/pkg_resources/__init__.py", line 968, in require
Jan 09 13:14:51 mailman3 mailman-web[24856]:     needed = self.resolve(parse_requirements(requirements))
Jan 09 13:14:51 mailman3 mailman-web[24856]:              ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
Jan 09 13:14:51 mailman3 mailman-web[24856]:   File "/usr/lib/python3.11/site-packages/pkg_resources/__init__.py", line 829, in resolve
Jan 09 13:14:51 mailman3 mailman-web[24856]:     dist = self._resolve_dist(
Jan 09 13:14:51 mailman3 mailman-web[24856]:            ^^^^^^^^^^^^^^^^^^^
Jan 09 13:14:51 mailman3 mailman-web[24856]:   File "/usr/lib/python3.11/site-packages/pkg_resources/__init__.py", line 870, in _resolve>
Jan 09 13:14:51 mailman3 mailman-web[24856]:     raise DistributionNotFound(req, requirers)

You need to migrate haystack from pkg_resources to importlib_resources, see https://importlib-resources.readthedocs.io/en/latest/migration.html

Actions #10

Updated by gladiac about 2 months ago

Either importlib_resources or importlib_metadata, depending on the feature used:
https://importlib-metadata.readthedocs.io/en/latest/migration.html

Actions #11

Updated by crameleon about 2 months ago

Thank you, @gladiac! I actually already wanted to reach out to you on IRC about this but haven't caught you online. :-) I will look into your advice.

Actions #12

Updated by gladiac about 2 months ago

crameleon wrote in #note-11:

Thank you, @gladiac! I actually already wanted to reach out to you on IRC about this but haven't caught you online. :-) I will look into your advice.

@asn:matrix.org is the easiest

Actions #13

Updated by crameleon about 1 month ago

Submitted a patch upstream: https://github.com/django-haystack/django-haystack/pull/1935.
Will test this together with Mailman and follow up with adding the patch to the package if successful.

Actions #14

Updated by crameleon about 1 month ago

And the next candidate!

Jan 12 22:32:20 mailman3 mailman-web[31744]:   File "/usr/lib/python3.11/site-packages/django_q/apps.py", line 3, in <module>
Jan 12 22:32:20 mailman3 mailman-web[31744]:     from django_q.conf import Conf
Jan 12 22:32:20 mailman3 mailman-web[31744]:   File "/usr/lib/python3.11/site-packages/django_q/conf.py", line 8, in <module>
Jan 12 22:32:20 mailman3 mailman-web[31744]:     import pkg_resources
Jan 12 22:32:20 mailman3 mailman-web[31744]:   File "/usr/lib/python3.11/site-packages/pkg_resources/__init__.py", line 3324, in <module>
Jan 12 22:32:20 mailman3 mailman-web[31744]:     @_call_aside
Jan 12 22:32:20 mailman3 mailman-web[31744]:      ^^^^^^^^^^^
Jan 12 22:32:20 mailman3 mailman-web[31744]:   File "/usr/lib/python3.11/site-packages/pkg_resources/__init__.py", line 3299, in _call_aside
Jan 12 22:32:20 mailman3 mailman-web[31744]:     f(*args, **kwargs)
Jan 12 22:32:20 mailman3 mailman-web[31744]:   File "/usr/lib/python3.11/site-packages/pkg_resources/__init__.py", line 3337, in _initialize_master_working_set
Jan 12 22:32:20 mailman3 mailman-web[31744]:     working_set = WorkingSet._build_master()
Jan 12 22:32:20 mailman3 mailman-web[31744]:                   ^^^^^^^^^^^^^^^^^^^^^^^^^^
Jan 12 22:32:20 mailman3 mailman-web[31744]:   File "/usr/lib/python3.11/site-packages/pkg_resources/__init__.py", line 631, in _build_master
Jan 12 22:32:20 mailman3 mailman-web[31744]:     ws.require(__requires__)
Jan 12 22:32:20 mailman3 mailman-web[31744]:   File "/usr/lib/python3.11/site-packages/pkg_resources/__init__.py", line 968, in require
Jan 12 22:32:20 mailman3 mailman-web[31744]:     needed = self.resolve(parse_requirements(requirements))
Jan 12 22:32:20 mailman3 mailman-web[31744]:              ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
Jan 12 22:32:20 mailman3 mailman-web[31744]:   File "/usr/lib/python3.11/site-packages/pkg_resources/__init__.py", line 829, in resolve
Jan 12 22:32:20 mailman3 mailman-web[31744]:     dist = self._resolve_dist(
Jan 12 22:32:20 mailman3 mailman-web[31744]:            ^^^^^^^^^^^^^^^^^^^
Jan 12 22:32:20 mailman3 mailman-web[31744]:   File "/usr/lib/python3.11/site-packages/pkg_resources/__init__.py", line 870, in _resolve_dist
Jan 12 22:32:20 mailman3 mailman-web[31744]:     raise DistributionNotFound(req, requirers)
Jan 12 22:32:20 mailman3 mailman-web[31744]: pkg_resources.DistributionNotFound: The 'flufl.lock>=4.0' distribution was not found and is required by hyperkitty

At this point I wonder if someone shouldn't have grep'd the whole Factory tree for pkg_resources beforehand. ;-)

Actions #16

Updated by crameleon about 1 month ago

It seems one should not use django-q anymore, but instead migrate to django-q2:

https://github.com/Koed00/django-q/pull/737#issuecomment-1890113894

Not sure I want to do this as part of the issue at hand. I think I will patch django-q downstream for now.

Actions #17

Updated by crameleon about 1 month ago

And, the next one, gunicorn!

Jan 12 23:30:45 mailman3 mailman[32567]:   File "/usr/lib/python3.11/site-packages/gunicorn/app/base.py", line 11, in <module>
Jan 12 23:30:45 mailman3 mailman[32567]:     from gunicorn import util
Jan 12 23:30:45 mailman3 mailman[32567]:   File "/usr/lib/python3.11/site-packages/gunicorn/util.py", line 25, in <module>
Jan 12 23:30:45 mailman3 mailman[32567]:     import pkg_resources
Jan 12 23:30:45 mailman3 mailman[32567]:   File "/usr/lib/python3.11/site-packages/pkg_resources/__init__.py", line 3324, in <module>
Jan 12 23:30:45 mailman3 mailman[32567]:     @_call_aside
Jan 12 23:30:45 mailman3 mailman[32567]:      ^^^^^^^^^^^
Jan 12 23:30:45 mailman3 mailman[32567]:   File "/usr/lib/python3.11/site-packages/pkg_resources/__init__.py", line 3299, in _call_aside
Jan 12 23:30:45 mailman3 mailman[32567]:     f(*args, **kwargs)
Jan 12 23:30:45 mailman3 mailman[32567]:   File "/usr/lib/python3.11/site-packages/pkg_resources/__init__.py", line 3337, in _initialize>
Jan 12 23:30:45 mailman3 mailman[32567]:     working_set = WorkingSet._build_master()
Jan 12 23:30:45 mailman3 mailman[32567]:                   ^^^^^^^^^^^^^^^^^^^^^^^^^^
Jan 12 23:30:45 mailman3 mailman[32567]:   File "/usr/lib/python3.11/site-packages/pkg_resources/__init__.py", line 631, in _build_master
Jan 12 23:30:45 mailman3 mailman[32567]:     ws.require(__requires__)
Jan 12 23:30:45 mailman3 mailman[32567]:   File "/usr/lib/python3.11/site-packages/pkg_resources/__init__.py", line 968, in require
Jan 12 23:30:45 mailman3 mailman[32567]:     needed = self.resolve(parse_requirements(requirements))
Jan 12 23:30:45 mailman3 mailman[32567]:              ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
Jan 12 23:30:45 mailman3 mailman[32567]:   File "/usr/lib/python3.11/site-packages/pkg_resources/__init__.py", line 829, in resolve
Jan 12 23:30:45 mailman3 mailman[32567]:     dist = self._resolve_dist(
Jan 12 23:30:45 mailman3 mailman[32567]:            ^^^^^^^^^^^^^^^^^^^
Jan 12 23:30:45 mailman3 mailman[32567]:   File "/usr/lib/python3.11/site-packages/pkg_resources/__init__.py", line 870, in _resolve_dist
Jan 12 23:30:45 mailman3 mailman[32567]:     raise DistributionNotFound(req, requirers)
Jan 12 23:30:45 mailman3 mailman[32567]: pkg_resources.DistributionNotFound: The 'flufl.lock>=5.1' distribution was not found and is 
Actions #18

Updated by crameleon about 1 month ago · Edited

Luckily, that one could be solved by vendor changing to the version in Tumbleweed.

So, Mailman is now running again with the patched django-haystack and django-q packages from my home project.
I will follow up with the SRs to Factory the devel projects, then we can hopefully get this into Factory.

Actions #21

Updated by crameleon about 1 month ago

  • Status changed from In Progress to Resolved

New Factory versions installed, my temporary repository removed.
Additionally cleaned up various packages from o:i:mailman3 which were in the meanwhile updated in Factory.

Actions

Also available in: Atom PDF