Project

General

Profile

Actions

action #151600

closed

sudo: package installing distro config file to /usr/etc makes test fail

Added by dimstar 3 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2023-11-28
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

A change sudo has been submitted https://build.opensuse.org/request/show/1128361 which installs the default configuration into /usr/etc
The sudo.pm test module (amonst some others) does some various tests - some still valid, some not anymore

  • adding config snippets to /etc/sudoers/d/$file => valid, and tests passing
  • sed'ing directly in /etc/sudoers -> the file is no longer installed in this location and thus sed fails; the expected config changes do thus not apply. Prior to editing the file, it should be ensured is copied from /usr/etc/sudoers to /etc/sudoers (if not yet existing)

openQA test in scenario opensuse-Staging:J-Staging-DVD-x86_64-yast2_users-staging@64bit fails in
sudo

Test suite description

Reproducible

Fails since (at least) Build J.575.1 (current job)

Expected result

Last good: J.575.1 (or more recent)

Further details

Always latest result in this scenario: latest

Actions #2

Updated by szarate 3 months ago

  • Tags set to bugbusters
  • Status changed from New to Resolved
  • Assignee set to dimstar

Already merged

Actions

Also available in: Atom PDF