Project

General

Profile

action #14102

[Build 2162] test user_settings_root fails to type confirmation password in second field

Added by okurz over 5 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2016-10-07
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-12-SP2-Server-DVD-aarch64-RAID5@aarch64 fails in
http://openqa.suse.de/tests/603782#step/user_settings_root/4
with failed needle 'rootpassword-typed' because the "sleep 1" switching between the password entry fields is probably unsafe.

Reproducible

Fails since (at least) Build 2162 (current job) but I could imagine this could happen depending on load sporadically.

Expected result

Last good: 2160 (or more recent)

suggestion

I think I expressed my feeling about "sleep" in test code ;-)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #14108: [Build 2162] test user_settings fails because a parenthesis that should end up in "logpackages" was typed too earlyResolved2016-10-07

Related to openQA Tests - action #13214: Next button is ignored in user_settings but works on second tryResolved2016-08-16

History

#1 Updated by zluo over 5 years ago

both links for results don't work...

#2 Updated by okurz over 5 years ago

yes, this happens when we wait long enough. Anyway, the description is still valid and the test module should be improved to get rid of sleep.

#3 Updated by okurz over 5 years ago

  • Status changed from New to Resolved
  • Assignee set to okurz

#4 Updated by okurz over 5 years ago

  • Related to action #14108: [Build 2162] test user_settings fails because a parenthesis that should end up in "logpackages" was typed too early added

#5 Updated by okurz over 5 years ago

  • Related to action #13214: Next button is ignored in user_settings but works on second try added

Also available in: Atom PDF