Project

General

Profile

Actions

action #138461

closed

pre-install zypper-migration-plugin for support image

Added by shukui 4 months ago. Updated 3 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
Target version:
Start date:
2023-10-25
Due date:
% Done:

0%

Estimated time:

Description

Motivation

When we optimize test coverage for the new test matrix, the supporting images for sles15sp3_x86_64 and sles15sp3_aarch64 lack zypper-migration-plugin (see https://openqa.suse.de/tests/12614984#step/pre_migration/14 and https://openqa.suse.de/tests/12634537#step/pre_migration/14), so we need to update the supporting images.

Acceptance criteria

AC1: pre-install the package zypper-migration-plugin in sles15sp3_x86_64 and sles15sp3_aarch64 supporting images.

Actions #1

Updated by shukui 4 months ago

  • Description updated (diff)
Actions #2

Updated by shukui 4 months ago

  • Status changed from New to In Progress
  • Assignee set to shukui
Actions #3

Updated by tinawang123 4 months ago

Same problem for image: autoyast-SLES-15-SP3-x86_64-SAP-updated.qcow2

Actions #4

Updated by tinawang123 4 months ago

Same problem : SLES-15-SP3-s390x-GM-gnome-allpatterns.qcow2

Actions #5

Updated by shukui 4 months ago

tinawang123 wrote in #note-4:

Same problem : SLES-15-SP3-s390x-GM-gnome-allpatterns.qcow2

Hi Tina, I cannot find this qcow2 image in https://openqa.suse.de/admin/job_templates/520?

Actions #7

Updated by rainerkoenig 4 months ago

  • Target version set to Current
Actions #8

Updated by syrianidou_sofia 3 months ago

I have merged the PR as it couldn't do any harm. Could you please make new support images and verify that the fix works?

Actions #9

Updated by shukui 3 months ago

syrianidou_sofia wrote in #note-8:

I have merged the PR as it couldn't do any harm. Could you please make new support images and verify that the fix works?

I've already tried this in the VRs, but it still failed with the same situation, seems the package is removed after it is pre-installed in support image while migration.

Actions #10

Updated by rfan1 3 months ago

shukui wrote in #note-9:

syrianidou_sofia wrote in #note-8:

I have merged the PR as it couldn't do any harm. Could you please make new support images and verify that the fix works?

I've already tried this in the VRs, but it still failed with the same situation, seems the package is removed after it is pre-installed in support image while migration.

Do we need the workaround mentioned in https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/18080 any more?

The package is not available on sle15sp6 now, IMO we may need to fix our test code if get confirmation from developer :)

Actions #11

Updated by leli 3 months ago

  • Status changed from In Progress to Rejected

The package zypper-migration-plugin is not needed for 15SP6 so we don't need pre-install it on base product also. So reject this ticket.

Actions

Also available in: Atom PDF