Project

General

Profile

action #13804

the overview filter is buggy if the parameter included ":" eg. Staging test overview

Added by mlin7442 about 6 years ago. Updated about 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Concrete Bugs
Target version:
-
Start date:
2016-09-19
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

if the parameter included ":" - colon in URL, in the staging test overview, clicking the Apply button multiple times in the overview filter, whatever the filtering condition in the overview filter, the parameter's value will converted to an weird value.

Reproducible step:
1) go to https://openqa.opensuse.org/tests/overview?version=Staging%3AI&groupid=2&build=590.1&distri=opensuse
2) checked whatever filtering condition and click apply button
3) if checked softfailed, then the URL being https://openqa.opensuse.org/tests/overview?result=softfailed&arch=&version=Staging%253AI&groupid=2&build=590.1&distri=opensuse# , "version" is Staging%253AI
4) click the apply button again, "version" being Staging%25253AI, keep appending "25"
5) unselected all condition and click the apply button, webui show you nothing because the "version"'s value is wrong

The issue also can found in master.

History

#1 Updated by mlin7442 about 6 years ago

  • Description updated (diff)

#2 Updated by coolo about 6 years ago

  • Assignee set to mkittler

as this is a very important use case, please also add a test case for this.

#3 Updated by mkittler about 6 years ago

  • Status changed from New to In Progress

#4 Updated by coolo about 6 years ago

  • Status changed from In Progress to Resolved

deployed and verified

Also available in: Atom PDF