Project

General

Profile

Actions

action #133772

closed

Munin making many requests on o3 size:M

Added by livdywan 8 months ago. Updated 8 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Regressions/Crashes
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

Observation

While investigating #132167 during the last mob session we noticed that the nginx endpoint /server-status?auto receives a very high number of requests from Munin (many thousands per hour). The data granularity in Munin is only 5 minutes however, so this seems a bit excessive and should probably be reduced.

Acceptance criteria

  • AC1: Munin does not cause an excessively large number of HTTP requests anymore

Suggestions

  • Ask Tina :)

Related issues 1 (0 open1 closed)

Copied from openQA Project - action #132167: asset uploading failed with http status 502 size:MResolvedkraih2023-06-292023-08-30

Actions
Actions #1

Updated by livdywan 8 months ago

  • Copied from action #132167: asset uploading failed with http status 502 size:M added
Actions #2

Updated by tinita 8 months ago

  • Status changed from Workable to In Progress
  • Assignee set to tinita

I can't see that many requests. Maybe goaccess was configured wrong.

new-ariel:/space/logs/nginx # head -1 /space/logs/nginx/access.log
195.135.221.150 - - [03/Aug/2023:00:00:06 +0000] "GET /admin/influxdb/minion?rc_fail_timespan_minutes=5 HTTP/1.1" 308 171 "-" "curl/8.0.1"
new-ariel:/space/logs/nginx # grep server-status /space/logs/nginx/access.log | wc -l
534
new-ariel:/space/logs/nginx # grep /influxdb /space/logs/nginx/access.log | wc -l
780

And we see that it's every 5 minutes:

new-ariel:/space/logs/nginx # grep server-status /space/logs/nginx/access.log | tail
127.0.0.1 - - [03/Aug/2023:14:45:05 +0000] "GET /server-status?auto HTTP/1.1" 308 171 "-" "munin/2.0.40 (libwww-perl/6.31)" rt=0.000 urt="-"
127.0.0.1 - - [03/Aug/2023:14:50:02 +0000] "GET /server-status?auto HTTP/1.1" 308 171 "-" "munin/2.0.40 (libwww-perl/6.31)" rt=0.000 urt="-"
127.0.0.1 - - [03/Aug/2023:14:50:04 +0000] "GET /server-status?auto HTTP/1.1" 308 171 "-" "munin/2.0.40 (libwww-perl/6.31)" rt=0.000 urt="-"
127.0.0.1 - - [03/Aug/2023:14:50:04 +0000] "GET /server-status?auto HTTP/1.1" 308 171 "-" "munin/2.0.40 (libwww-perl/6.31)" rt=0.000 urt="-"
127.0.0.1 - - [03/Aug/2023:14:55:03 +0000] "GET /server-status?auto HTTP/1.1" 308 171 "-" "munin/2.0.40 (libwww-perl/6.31)" rt=0.000 urt="-"
127.0.0.1 - - [03/Aug/2023:14:55:05 +0000] "GET /server-status?auto HTTP/1.1" 308 171 "-" "munin/2.0.40 (libwww-perl/6.31)" rt=0.000 urt="-"
127.0.0.1 - - [03/Aug/2023:14:55:05 +0000] "GET /server-status?auto HTTP/1.1" 308 171 "-" "munin/2.0.40 (libwww-perl/6.31)" rt=0.000 urt="-"
127.0.0.1 - - [03/Aug/2023:15:00:03 +0000] "GET /server-status?auto HTTP/1.1" 308 171 "-" "munin/2.0.40 (libwww-perl/6.31)" rt=0.000 urt="-"
127.0.0.1 - - [03/Aug/2023:15:00:04 +0000] "GET /server-status?auto HTTP/1.1" 308 171 "-" "munin/2.0.40 (libwww-perl/6.31)" rt=0.000 urt="-"
127.0.0.1 - - [03/Aug/2023:15:00:05 +0000] "GET /server-status?auto HTTP/1.1" 308 171 "-" "munin/2.0.40 (libwww-perl/6.31)" rt=0.000 urt="-"
Actions #3

Updated by tinita 8 months ago

  • Subject changed from Munin causing excessive load on o3 size:M to Munin making many requests on o3 size:M
  • Priority changed from Urgent to Normal

Closing because goaccess apparently reported wrong data.
If I call it on access.log now I don't see that url in the top requests.

Actions #4

Updated by tinita 8 months ago

  • Status changed from In Progress to Resolved
Actions

Also available in: Atom PDF