Project

General

Profile

action #13118

SLED "regression": all evolution tests are broken

Added by qkzhu over 5 years ago. Updated about 5 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2016-08-10
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

observation

https://openqa.suse.de/tests/509150

potentially product issue

History

#1 Updated by qkzhu over 5 years ago

The 'Continue' button of evolution setup wizard of this case has changed to 'Next' on SLED12SP2.
evolution_smoke

#2 Updated by coolo over 5 years ago

  • Priority changed from Normal to High

We still see that in SP2 builds.

#3 Updated by qkzhu over 5 years ago

see:https://openqa.suse.de/tests/621823

  • evolution_smoke
  • evolution_mail_imap
  • evolution_mail_pop
  • evolution_meeting_imap
  • evolution_meeting_pop
    have been fixed.

  • evolution_mail_ews

  • evolution_task_ews
    are blocked due to the zzzSUSEExTest19@microfocus.com(MS Exchange account) is expired.

  • evolution_timezone_setup
    I will fix this case in the next few days.

#4 Updated by qkzhu over 5 years ago

  • Status changed from New to In Progress

#5 Updated by coolo over 5 years ago

can you take out the ews tests for now? They block automatic SP1 updates

#6 Updated by qkzhu over 5 years ago

coolo wrote:

can you take out the ews tests for now? They block automatic SP1 updates

Removed: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/2020

And we also have a ticket for the disabled exchange mail account: #RF103644

#7 Updated by qkzhu over 5 years ago

qkzhu wrote:

  • evolution_timezone_setup

PR: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/2017

validation run: http://147.2.212.239/tests/854

evolution_timezone_setup passed on my local server for SP2, but it failed in SP1:
https://openqa.suse.de/tests/622354#step/evolution_timezone_setup/11

the send_key "alt-s" for skip lookup seems doesn't have effect.
I have compared the autoinst-log, all the actions are executed timely, so it not caused
by a slow worker but the looking up finished in a very short time.

I will keep an eye on this for the next few builds

#8 Updated by qkzhu over 5 years ago

  • evolution_timezone_setup
  1. Change testing account to internal_account_A to avoid unstable lookup process Sometimes this case failed at the lookup step, previously we use an aim account which will got all the account info via the internet in the lookup process. And we will assert the screen and click the button to skip this step, sometimes the process is too quick to skip it.
  2. Use setup_pop in x11regressiontest.pm to setup the account

PR: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/2041

validation run on SP2:http://147.2.212.239/tests/856

validation run on SP1:http://147.2.212.239/tests/857

#9 Updated by qkzhu about 5 years ago

Failed at: https://openqa.suse.de/tests/626482#step/evolution_timezone_setup/82

  • evolution_timezone_setup

Enter timezone drop-down menu using shortcut instead of assert_and_click

PR: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/2053

validation run SP1: http://147.2.212.239/tests/863

validation run SP2: http://147.2.212.239/tests/858

#10 Updated by okurz about 5 years ago

  • Category set to Bugs in existing tests

#11 Updated by qkzhu about 5 years ago

Refactoring and dedup evolution cases

coolo has submitted three commits to dedup the evolution cases in:

So this is the fourth (and hope it's the last) commit to dedup evolution cases.

see also: poo#13118

PR: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/2128

Validation on SP2: http://147.2.212.239/tests/966

Validation on SP1: http://147.2.212.239/tests/967

#12 Updated by qkzhu about 5 years ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF