Project

General

Profile

Actions

action #131027

closed

openqa-trigger-from-obs circleCI job running against master fails due to "Package 'python3-black' not found." size:M

Added by okurz 10 months ago. Updated 10 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Regressions/Crashes
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

Observation

https://app.circleci.com/pipelines/github/os-autoinst/openqa-trigger-from-obs/743/workflows/f4279542-337f-4256-8f14-81d12ff1065a/jobs/1676
running on Leap 15.4 . We need to upgrade to Leap 15.5 anyway, see #130582

Suggestions

  • Update https://github.com/os-autoinst/openqa-trigger-from-obs/blob/master/.circleci/config.yml to use either Leap 15.5 and check if the problem is still present or use a different container base, e.g. from devel:openQA:ci if that helps
  • Optionally: Create a dedicated CI container image as we do for other projects including all necessary dependencies directly to avoid any additional zypper calls in CI repeatedly
  • Ensure that at least one nightly job against the master branch is passed again
Actions #1

Updated by okurz 10 months ago

  • Subject changed from openqa-trigger-from-obs circleCI job running against master fails due to "Package 'python3-black' not found." to openqa-trigger-from-obs circleCI job running against master fails due to "Package 'python3-black' not found." size:M
  • Description updated (diff)
  • Status changed from New to Workable
Actions #2

Updated by osukup 10 months ago

  • Status changed from Workable to In Progress
  • Assignee set to osukup
Actions #3

Updated by osukup 10 months ago

  • Status changed from In Progress to Feedback
Actions #5

Updated by osukup 10 months ago

  • Status changed from Feedback to Resolved

unit tests use now Leap 15.5 and style check tumbleweed

Actions

Also available in: Atom PDF