Project

General

Profile

Actions

communication #129187

closed

openSUSE:infrastructure clamav-milter conflicts clamav

Added by bmwiedemann about 1 year ago. Updated 26 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Email
Target version:
-
Start date:
2023-05-12
Due date:
% Done:

100%

Estimated time:

Description

Observed on mx2 and monitor.i.o.o
automatic zypper -n upgrade was blocked by a file conflict:

File /usr/sbin/clamav-milter
  from install of
     clamav-0.103.8-150000.3.44.1.x86_64 (Update repository with updates from SUSE Linux Enterprise 15)
  conflicts with file from install of
     clamav-milter-0.103.8-lp154.2.1.x86_64 (openSUSE:infrastructure)
Actions #1

Updated by bmwiedemann about 1 year ago

  • % Done changed from 0 to 50

probably solved with

sudo zypper -n in -f clamav-0.103.8-lp154.2.1
Actions #2

Updated by pjessen about 1 year ago

Odd that both packages should have /usr/sbin/clamav-milter.

Actions #3

Updated by crameleon about 1 year ago

According to the changelog of the clamav package, the clamav-milter was split out of clamav at one point. The clamav package in the 15.4 Update channel does not yet have this subpackage. Hence this is at most an issue with the repository configuration on the target system. Ideally the main clamav package should be installed from openSUSE:infrastructure as well on said system.

Actions #4

Updated by crameleon about 1 year ago

  • Status changed from New to Closed
  • % Done changed from 50 to 80

Resolved some of these conflicts as part of 15.5 upgrades by vendor changing the affected packages to openSUSE:infrastructure.

Actions #5

Updated by crameleon 26 days ago

  • Status changed from Closed to Resolved
  • % Done changed from 80 to 100

With 15.6 the distribution package is now recent enough and the o:i one was removed.

Actions

Also available in: Atom PDF