Project

General

Profile

Actions

action #127799

closed

[qe-core][functional]test fails in ovs_server, we may need to test openvswitch3* packages

Added by rfan1 11 months ago. Updated 9 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-15-SP5-Online-x86_64-ovs-server@64bit fails in
ovs_server

Test suite description

Testsuite maintained at https://gitlab.suse.de/qa-maintenance/qam-openqa-yml. Maintainer : Anna Minou
Regression test for openvswitch-ipsec (server-side).

Reproducible

Fails since (at least) Build 90.1

Expected result

Last good: 88.1 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues 1 (0 open1 closed)

Related to openQA Tests - action #127580: [qe-core][functional]test fails in ovn [we may need to test ovn3]Resolvedrfan12023-04-13

Actions
Actions #1

Updated by rfan1 11 months ago

  • Related to action #127580: [qe-core][functional]test fails in ovn [we may need to test ovn3] added
Actions #2

Updated by zluo 11 months ago

  • Assignee set to zluo

at moment we don't have openvswitch3 yet, not available on Tumbleweed and sles 15 sp5. We need to wait and check how we can handle this change from ovs.
take over

Actions #3

Updated by zluo 11 months ago

  • Start date deleted (2023-04-18)
Actions #4

Updated by zluo 11 months ago

  • Subject changed from [qe-core][functional]test fails in ovs_server, we may need to test openvswith3* packages to [qe-core][functional]test fails in ovs_server, we may need to test openvswitch3* packages
Actions #5

Updated by zluo 11 months ago

with sles 15 sp5 rc build93.2 we have now required packages:

Informationen zu Paket openvswitch3:

Repository : SLE-Module-Server-Applications15-SP5-Pool
Name : openvswitch3
Version : 3.1.0-150500.1.1
Arch : x86_64
Anbieter : SUSE LLC https://www.suse.com/
Support Level : Stufe 3
Installierte Größe : 1,3 MiB
Installiert : Ja
Status : aktuell
Quellpaket : openvswitch3-3.1.0-150500.1.1.src
Upstream-URL : http://openvswitch.org/
Zusammenfassung : A multilayer virtual network switch
Beschreibung :
Open vSwitch is a multilayer virtual network Ethernet switch. It is
enables network automation through programmatic extension, and
supports standard management interfaces and protocols (e.g. NetFlow,
sFlow, RSPAN, ERSPAN, CLI, LACP, 802.1ag). In addition, it supports
distribution across multiple physical servers similar to VMware’s
vNetwork distributed vswitch or Cisco’s Nexus 1000V.

Actions #6

Updated by zluo 10 months ago

  • Status changed from New to Workable

https://openqa.suse.de/tests/11021669#step/ovs_server/31

let me check if I can change something now so that required packages can be installed.

Actions #7

Updated by zluo 10 months ago

  • Status changed from Workable to In Progress

failed because of following:
zypper_call('in openvswitch-ipsec tcpdump openvswitch-pki openvswitch-vtep', timeout => 300);
we have now product change in this relation, some packages belong to repository SLE-Module-Legacy15-SP5-Pool, that is why zypper_call failed.

Actions #8

Updated by zluo 10 months ago

https://openqa.suse.de/tests/11024375
https://openqa.suse.de/tests/11024376

ovs_client and ovs_server work with my PR (WIP).

Actions #10

Updated by zluo 10 months ago

at moment we have openvswitch3-ipsec openvswitch3-pki openvswitch3-vtep on sles 15 sp5, but these new packages are not available yet on opensuse.

So we need to take care of this and change later again.

Actions #11

Updated by zluo 10 months ago

we have at moment an issue on tumbleweed: https://bugzilla.opensuse.org/show_bug.cgi?id=1210479
openvswitch-ipsec fails to start

anyway these change has no impact on tumbleweed. Hope above bug can be fixed soon.

Actions #12

Updated by zluo 9 months ago

  • Status changed from In Progress to Resolved

PR merged and it looks good on osc since a couple of builds, resolved.
see https://openqa.suse.de/tests/11163526

Actions

Also available in: Atom PDF