Project

General

Profile

action #12596

s390: wait serial output in "logpackages" and "consoletest_setup" is lost

Added by okurz about 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
-
Target version:
-
Start date:
2016-07-04
Due date:
% Done:

90%

Estimated time:
Difficulty:

Description

observation

https://openqa.suse.de/tests/460214#step/install_and_reboot/3 shows that the expected serial output can not be found but the command execution looks ok.

steps to reproduce

looks like sporadic only on s390x@zVM

problem

maybe related to #12410

H1: iucvconn gets killed somehow

suggestion

First it fails in non-fatal test #12594

workaround

probably workaround


Related issues

Related to openQA Project - action #23404: Serial output gets lostResolved2017-08-16

Blocks openQA Tests - action #12410: s390 dasdfmt fails even though command looks complete in screenshotResolved2016-06-20

History

#1 Updated by okurz about 5 years ago

  • Related to action #12410: s390 dasdfmt fails even though command looks complete in screenshot added

#3 Updated by okurz about 5 years ago

  • Subject changed from s390: wait serial output in "logpackages" is lost to s390: wait serial output in "logpackages" and "consoletest_setup" is lost

also in "consoletest_setup": https://openqa.suse.de/tests/462358

#4 Updated by okurz about 5 years ago

  • Priority changed from Normal to Urgent

this seems to be more and more severe, also happens on zkvm, see https://openqa.suse.de/tests/461590#step/consoletest_setup/26
maybe the last change by Ihno to our s390 hosts?

#6 Updated by okurz about 5 years ago

also happens in bootloader step, see https://openqa.suse.de/tests/464910

#7 Updated by okurz about 5 years ago

applied fix for trying the debug output together with mgriessmeier: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/1529
let's see how this turns out.

#8 Updated by mgriessmeier about 5 years ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 90

applied another fix with https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/1533

Always show us Debug output to have easier debugging

#9 Updated by mgriessmeier about 5 years ago

wait_serial issue after fix was applied in:
https://openqa.suse.de/tests/479875#step/bootloader_s390/7

-> restart helped though...

what looks odd to me is this:
Use of uninitialized value $r in concatenation (.) or string at /var/lib/openqa/share/tests/sle-12-SP1/tests/installation/bootloader_s390.pm line 199.
09:48:43.1845 3110 # Test died:
dasd_configure died with exit code at /var/lib/openqa/share/tests/sle-12-SP1/tests/installation/bootloader_s390.pm line 199.

#10 Updated by mgriessmeier about 5 years ago

  • Description updated (diff)

In https://openqa.suse.de/tests/482355 we can see in our implemented debug output, that there is no iucvconn running via sshd -> added H1

#11 Updated by okurz about 5 years ago

  • Related to deleted (action #12410: s390 dasdfmt fails even though command looks complete in screenshot)

#12 Updated by okurz about 5 years ago

  • Blocks action #12410: s390 dasdfmt fails even though command looks complete in screenshot added

#13 Updated by mgriessmeier almost 5 years ago

  • Status changed from In Progress to Resolved

not happening for a long time - considering as fixed

#14 Updated by okurz about 4 years ago

Also available in: Atom PDF