Project

General

Profile

action #12348

action #11564: s390x: add SSH+GUI as frontend to the Installation process

ssh-X has some issues with resizing

Added by mgriessmeier almost 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Enhancement to existing tests
Target version:
-
Start date:
2016-06-15
Due date:
% Done:

0%

Estimated time:
Difficulty:
Duration:

Description

observation

https://openqa.suse.de/tests/445897#step/skip_registration/8 fails because the window in foreground could not be maximized using xdotools

steps to reproduce

ssh-X installation on zVM, reproducible every time since https://openqa.suse.de/tests/445034

problem

last good: https://openqa.suse.de/tests/444717

History

#1 Updated by okurz almost 4 years ago

  • Description updated (diff)

#2 Updated by okurz almost 4 years ago

  • Description updated (diff)

zVM, I meant zVM, not zkvm

#3 Updated by mgriessmeier almost 4 years ago

  • Assignee changed from mgriessmeier to okurz

Window got resized back to default after "System Probing"
https://openqa.suse.de/tests/446226#step/skip_registration/9

okurz tries to reproduce it manually and has a look on yast changes between Builds 1616 and 1621

#4 Updated by okurz almost 4 years ago

I didn't find anything related in changelog difference with

arch=s390x old=1616 new=1621 base=Beta2; vimdiff http://xcdchk.suse.de/browser/data/SLE-12-SP2-Server/Build${old}/${arch}/ChangeLog-${base}-Build${old}.txt http://xcdchk.suse.de/browser/data/SLE-12-SP2-Server/Build${new}/${arch}/ChangeLog-${base}-Build${new}.txt

The return value of the system call on xdotools might need to be checked but the resizing seems to work, just resizes afterwards.

I will try to reproduce the first bad, then the last good.

http://lord.arch/tests/1390 through http://lord.arch/tests/1394 reproduce this issue on Build1621 (5/5), http://lord.arch/tests/1395 through http://lord.arch/tests/1399 show that Build1616 is still working fine (5/5) so definitely product change that introduced this.

#5 Updated by lslezak almost 4 years ago

I have tried an SSH installation with build 1621 in a x86_64 VM. I noticed that during initialization the YaST window was closed and then reopened again.
However, the reopened window had the same size as the original window.

I have checked the logs and it turned out that YaST was restarted:

clients/installation.rb:92 Installation ret:restart_yast`

That's because of the self-update feature https://fate.novell.com/319716.

Unfortunately I have no idea why the reopened window has a different size :-(

#6 Updated by okurz almost 4 years ago

  • Status changed from New to Feedback

filed as product bug - before I saw the discussion on irc://chat.freenode.net/yast that this is already worked on ;-) - https://bugzilla.suse.com/show_bug.cgi?id=985055

We might need to call "xdotool" again depending on how the product will behave but let's wait for YaST team's work on this

#7 Updated by lslezak almost 4 years ago

The Welcome step calls "ensure_fullscreen" (https://openqa.suse.de/tests/446226/modules/welcome/steps/1/src), the same should be called also later (in https://openqa.suse.de/tests/446226/modules/skip_registration/steps/1/src ?)

Please fix this on the openQA side as the YaST solution would be too complicated and require too much effort with small gain in the end... :-(
Thank you!

#8 Updated by okurz almost 4 years ago

PR https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/1478 as workaround to set window to fullscreen again in the step when application restarts after self-update. merged.

had to recreate the windowborder needle because of differing font. Initial needle was an icewm no my computer, the worker is running yet another font. https://openqa.suse.de/tests/447597 might prove it's working after the job finishes.

#9 Updated by okurz almost 4 years ago

  • Status changed from Feedback to Resolved

not failed recently, also we added a test to test installer self-updating as well as disabled self-updating. Looks good.

Also available in: Atom PDF