Project

General

Profile

action #120579

test fails in openqa_worker

Added by tinita 3 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Concrete Bugs
Target version:
Start date:
2022-11-15
Due date:
2022-11-30
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario openqa-Tumbleweed-dev-x86_64-openqa_install+publish@64bit-2G fails in
openqa_worker

Test suite description

Maintainer: okurz@suse.de Test for installation of openQA itself. To be used with "openqa" distri. Publishes an qcow2 image including the openQA installation ready to run as an appliance.

Reproducible

Fails since (at least) Build :TW.12731 (current job)

Expected result

Last good: :TW.12730 (or more recent)

Further details

Always latest result in this scenario: latest

Log excerpt

[  226.197565] worker[4899]: Use of uninitialized value in concatenation (.) or string at /usr/share/openqa/script/../lib/OpenQA/Worker.pm line 113.
[  226.203678] worker[4899]:    OpenQA::Worker::log_setup_info(OpenQA::Worker=HASH(0x55d8f161e020)) called at /usr/share/openqa/script/worker line 118
[  226.205414] worker[4899]: [info] worker 1:
[  226.206040] worker[4899]:  - config file:                      /etc/openqa/workers.ini
[  226.209687] worker[4899]:  - name used to register:
[  226.210650] worker[4899]:  - worker address (WORKER_HOSTNAME): undetermined
[  226.212016] worker[4899]:  - isotovideo version:               33
[  226.213383] worker[4899]:  - websocket API version:            1
[  226.214637] worker[4899]:  - web UI hosts:                     localhost
[  226.220105] worker[4899]:  - class:                            ?
[  226.223911] worker[4899]:  - no cleanup:                       no
[  226.224806] worker[4899]:  - pool directory:                   /var/lib/openqa/pool/1
[  226.226920] worker[4899]: [info] Project dir for host localhost is /var/lib/openqa/share
[  226.228605] worker[4899]: [info] Registering with openQA localhost
[  226.335821] worker[4899]: [error] Failed to register at localhost - 400 response: Erroneous parameters (host missing) - ignoring server
[  226.343931] worker[4899]: [error] Stopping because registration with all configured web UI hosts failed

Looks like this could be related to the WORKER_HOSTNAME change?


Related issues

Related to openQA Infrastructure - action #120261: tests should try to access worker by WORKER_HOSTNAME FQDN but sometimes get 'worker2' or something auto_review:".*curl.*worker\d+:.*failed at.*":retry size:meowResolved2022-11-10

History

#1 Updated by tinita 3 months ago

  • Project changed from openQA Tests to openQA Project
  • Category changed from Bugs in existing tests to Concrete Bugs
  • Target version set to Ready

#2 Updated by okurz 3 months ago

  • Related to action #120261: tests should try to access worker by WORKER_HOSTNAME FQDN but sometimes get 'worker2' or something auto_review:".*curl.*worker\d+:.*failed at.*":retry size:meow added

#3 Updated by okurz 3 months ago

  • Due date set to 2022-11-30
  • Status changed from New to Feedback
  • Assignee set to okurz

#4 Updated by okurz 3 months ago

  • Status changed from Feedback to New
  • Assignee changed from okurz to mkittler

PR merged. Of course this really only handles the warning not the root cause.

mkittler please take a look into the failing hostname initialization.

#5 Updated by mkittler 3 months ago

  • Status changed from New to In Progress

#6 Updated by mkittler 3 months ago

  • Status changed from In Progress to Resolved

The PR has been merged and the latest job has been passing again: https://openqa.opensuse.org/tests/2881329

Also available in: Atom PDF