Project

General

Profile

action #116854

Install curl if not present when running script_output with content fetched through HTTP

Added by JERiveraMoya 3 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
High
Assignee:
Target version:
Start date:
2022-09-20
Due date:
% Done:

0%

Estimated time:

Description

Motivation

Packages dependencies are not the same among architectures and although we could consider to have soft-failure for bsc#1193818 it is also reasonable to say that in a minimal system curl might not be there. Therefore we could just install curl if it is not already installed.

The root cause is how the content of the script is fetched sometimes:
https://github.com/os-autoinst/os-autoinst/blob/f206b29cea0413102e98b887e71a0d45b5698192/testapi.pm#L1112
We could force it to be always typed, but as the failing test are running everywhere with different environment conditions, we should not go that way, because we could also find a mistyping issue.

Following jobs are failing due to the issue described:
https://openqa.suse.de/tests/9516502#step/zypper_lifecycle/20
https://openqa.suse.de/tests/9516778#step/zypper_lifecycle/20
https://openqa.suse.de/tests/9517738#step/orphaned_packages_check/6
https://openqa.suse.de/tests/9518791#step/orphaned_packages_check/6

Acceptance criteria

AC1:: Install curl if it is not installed with a comment explanation before the failing line for both test suites listed above
AC2:: Report in the bug that we added as normal behavior

History

#1 Updated by JERiveraMoya 3 months ago

  • Project changed from openQA Tests to qe-yam
  • Category deleted (Bugs in existing tests)
  • Target version set to Current

#2 Updated by leli 2 months ago

Checked, agree with description of the ticket.

#3 Updated by coolgw 2 months ago

Checked.

#4 Updated by JERiveraMoya 2 months ago

  • Priority changed from Normal to High

#5 Updated by JERiveraMoya about 2 months ago

  • Tags deleted (qe-yast-refinement)
  • Status changed from New to Workable

#6 Updated by tinawang123 about 2 months ago

  • Status changed from Workable to In Progress

#7 Updated by tinawang123 about 2 months ago

  • Assignee set to tinawang123

#10 Updated by tinawang123 about 2 months ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF