Project

General

Profile

action #115943

openQA message box becomes invisible when scroll bar is present

Added by ph03nix 3 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Concrete Bugs
Target version:
Start date:
2022-08-29
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA info box messages that require a vertical scrollbar become practically invisible whenever the scroll bar is shown. See e.g. the attached screenshot:

Steps to reproduce

  • Hover over the scroll bar of any openQA message that requires scrolling

Impact

Debugging and reading some error message requires almost surgical precision with the mouse work and becomes very annoying.

Suggestion

  • Add more space between the text and the scrollbar to allow the text being completely visible, also if the scroll bar is shown or
  • Alternatively: Add a line break at the end.

Workaround

  • Use the serial output log instead of the webui
artemisI.png (172 KB) artemisI.png ph03nix, 2022-08-29 13:03
fixed.png (48.8 KB) fixed.png ph03nix, 2022-09-01 09:36
13715
13747

History

#1 Updated by jbaier_cz 3 months ago

At first, I was not able to reproduce (I am using Chromium) and wanted to ask for more info. Then I recalled to also try it in Firefox... somehow Firefox has trouble to add scrollbar into that space. It seems that something small like https://github.com/os-autoinst/openQA/pull/4789 should do the trick.

For the record, the problematic part can be found at: https://openqa.suse.de/tests/9180147#step/img_proof/87

#2 Updated by ph03nix 3 months ago

Jan, if this works, then you're awesome. Otherwise you're a little bit less but still awesome ;-)

Thanks for the quick fix, let's hope it works.

#3 Updated by jbaier_cz 3 months ago

  • Category set to Concrete Bugs
  • Status changed from New to Feedback
  • Assignee set to jbaier_cz
  • Target version set to Ready

The fix is merged, so let's see how it will look like after the deployment.

#4 Updated by ph03nix 3 months ago

13747

Looks good to me now:

From what I can see this ticket is resolved. Feel free to close it.

#5 Updated by jbaier_cz 3 months ago

  • Status changed from Feedback to Resolved

#6 Updated by ph03nix 3 months ago

Thanks Jan! :-)

Also available in: Atom PDF