Project

General

Profile

Actions

action #114403

closed

[qe-core] openQA doesn't give red or fail the case there even test fails in smt_server_install

Added by rfan1 almost 2 years ago. Updated 10 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Enhancement to existing tests
Target version:
Start date:
2022-07-20
Due date:
% Done:

100%

Estimated time:
4.00 h
Difficulty:

Description

Observation

We can see lots of error messages there, in this test module, but seems we can still get return 0.

openQA test in scenario sle-12-SP5-Server-DVD-Updates-x86_64-qam-smt-server-install@64bit fails in
smt_server_install

Test suite description

Testsuite maintained at https://gitlab.suse.de/qa-maintenance/qam-openqa-yml.

Reproducible

Fails since (at least) Build 20220714-1

Expected result

Last good: 20220712-1 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues 1 (0 open1 closed)

Related to openQA Tests - action #113788: [qe-core] test fails in system_prepare - no space left on deviceResolvedrfan12022-07-19

Actions
Actions #1

Updated by rfan1 almost 2 years ago

  • Category changed from Bugs in existing tests to Enhancement to existing tests
  • Target version set to QE-Core: Ready

https://openqa.suse.de/tests/9176046#step/smt_server_install/50

I need double check if it is expected result then the mirror process doesn't quit with errors.
And I would ask for some experts' help for smt server setup.

Actions #2

Updated by rfan1 almost 2 years ago

  • Related to action #113788: [qe-core] test fails in system_prepare - no space left on device added
Actions #3

Updated by rfan1 almost 2 years ago

  • Assignee set to rfan1
  • Estimated time set to 4.00 h

https://bugzilla.suse.com/show_bug.cgi?id=1201738

File the bug above and try to enhance our test code make sure we can quit the test if any issue with "smt-mirror" process.

Action:
Check the log file to make sure no error messages.

Actions #4

Updated by rfan1 almost 2 years ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 40
Actions #5

Updated by rfan1 almost 2 years ago

  • Status changed from In Progress to Feedback
  • % Done changed from 40 to 90
Actions #6

Updated by rfan1 almost 2 years ago

  • Status changed from Feedback to In Progress
  • % Done changed from 90 to 80
Actions #7

Updated by rfan1 over 1 year ago

@szarate,

Can you please double check this ticket? I think we can hold on to merge https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/15261

Because I think assert_script_run "tail -2 /var/log/smt/smt-mirror.log | grep 'Errors: : 0'"; is a bit strict for smt server sync, I may need check with migration team to see if we can have better solution to handle the error during data sync.

Actions #8

Updated by szarate over 1 year ago

It hasn't really failed in quite some time, so I guess we can wait a bit more

Actions #9

Updated by rfan1 over 1 year ago

  • Status changed from In Progress to Feedback
Actions #10

Updated by rfan1 10 months ago

  • Status changed from Feedback to Closed
  • % Done changed from 80 to 100

close this ticket since the test is more stable now

Actions

Also available in: Atom PDF