Project

General

Profile

Actions

action #113776

closed

[qa-tools] wrong test result 'failed' and wrong orders of running tests showed, autoinst-log is missing

Added by zluo over 1 year ago. Updated over 1 year ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Support
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-gnome@64bit fails in
force_scheduled_tasks

Test suite description

Reproducible

Fails since (at least) Build 20220714

Expected result

Last good: 20220214 (or more recent)

Further details

Always latest result in this scenario: latest

@mkittler, please help to check this issue, since there is no autoinst-log available, I can only tell that it took very long time to get finish with uploading logs. Might be the worker performance was also poor, nevertheless it should not show as failed, except some modules were skipped (none). Thanks!

other Info: openQA updat to date on Leap 15.3 (updated as well)


Files

Actions #1

Updated by zluo over 1 year ago

  • Subject changed from wrong test result 'failed' and wrong orders of running tests showed, autoinst-log is missing to [qa-tools] wrong test result 'failed' and wrong orders of running tests showed, autoinst-log is missing
Actions #2

Updated by mkittler over 1 year ago

  • Project changed from openQA Tests to openQA Project
  • Category changed from Spike/Research to Support

What version of os-autoinst and openQA and openQA-worker have you been using (from official Leap repos or from our devel repos)? If you're using anything from official Leap repos and I newer version is provided by our devel repos, I recommended upgrade to the latest version from our devel repos. Without logs I can also not tell anything more specific. Note that at least the worker log can also be found in the systemd journal. Since I can only guess I'd say some network issues might have prevented the upload of certain test modules. That the test is considered failed when not all test modules could have been uploaded is normal.

Actions #3

Updated by okurz over 1 year ago

  • Target version set to Ready
Actions #4

Updated by zluo over 1 year ago

  • Status changed from New to Rejected

@mkittler thanks for the reply! openqa devel repos are used on Leap 15.3.

But now I think this is more related to poor performance or network issue on my vm of conan. I've set up another remote worker (orthos machine) and it looks much better: http://10.162.30.85/tests

Actions

Also available in: Atom PDF