Project

General

Profile

action #113345

qem-bot does not ignore Development/Leap job groups as it should size:M

Added by mgrifalconi about 1 month ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

Observation

Bot does not ignore Development/Leap job groups and could block update approvals due to broken development tests.
See http://dashboard.qam.suse.de/blocked and look for "leap"

Problem

Likely regression due to https://github.com/openSUSE/qem-bot/commit/d4d33720d183ba30b63529577e2bbad700b238cd
or https://github.com/openSUSE/qem-bot/commit/c869a5cb7a56cdb5c3ba33f64e086f34c64ce5b9#diff-dbb33d499407c366ab760f232[…]e02dad0dd506c87b478b8007cf496ad

Suggestions

Look hard at the above commits and try it out with "--dry-run" and fix it. We at least know that jobs are still ignored, e.g. https://gitlab.suse.de/qa-maintenance/bot-ng/-/jobs/1044528#L2663 shows "INFO: Ignoring job '9078831' in development group 'Maintenance: Leap 15.4 Incidents'" so there is at least some ignoring going on

History

#1 Updated by okurz about 1 month ago

  • Assignee changed from osukup to okurz
  • Target version set to Ready

#2 Updated by okurz about 1 month ago

  • Description updated (diff)

#3 Updated by cdywan about 1 month ago

  • Subject changed from Bot do not ignore Development/Leap job groups to qem-bot does not ignore Development/Leap job groups as it should size:M
  • Description updated (diff)
  • Status changed from New to Workable

#4 Updated by okurz about 1 month ago

  • Due date set to 2022-07-22
  • Status changed from Workable to In Progress

Following instructions in https://github.com/openSUSE/qem-dashboard/issues/61 I did:

smachinectl shell postgresql
sudo -u postgres psql dashboard_db
select count(*) from openqa_jobs where flavor ~ 'Leap' and version = '15.4' and group_id=432;

and got

 count 
-------
   228
(1 row)

I just deleted them with

delete from openqa_jobs where flavor ~ 'Leap' and version = '15.4' and group_id=432;

I could also just have created a temporary table and move there for investigation or just delete the not passed jobs but nevermind. Let's see if they reappear. I will monitor.

#5 Updated by okurz about 1 month ago

  • Status changed from In Progress to Feedback

Jobs haven't reappeared since then. Likely still the same issue as https://github.com/openSUSE/qem-dashboard/issues/61 and #109310 due to an existing incident id being reused.

#6 Updated by okurz about 1 month ago

there were some Leap 15.3 jobs which I refrained from deleting myself, but osukup helped with that today. I think we need to improve or at least provide such guidance in docs.

#8 Updated by okurz about 1 month ago

  • Tags set to reactive work

#9 Updated by okurz about 1 month ago

  • Due date deleted (2022-07-22)
  • Status changed from Feedback to Resolved

Also available in: Atom PDF