Project

General

Profile

action #112277

[qe-core] test fails in update_install - rust test should not install cargo/rls

Added by mgrifalconi 2 months ago. Updated 8 days ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

According to Marcus Meissner investigation, the test installs "cargo" and "rls" even though it should not. More info at https://suse.slack.com/archives/C02D16TCP99/p1654854438113049

openQA test in scenario sle-15-SP3-Server-DVD-Incidents-Install-x86_64-qam-incidentinstall@64bit fails in
update_install

This is currently blocking the rust update approval.

Test suite description

Testsuite maintained at https://gitlab.suse.de/qa-maintenance/qam-openqa-yml. Incident Installation TEST
MAX_JOB_TIME=9000 due to long texlive update

Reproducible

Fails since (at least) Build :24558:rust (current job)

Expected result

Last good: :24147:netty-tcnative (or more recent)

Further details

Always latest result in this scenario: latest

Suggestions

  1. Package rls is added as a conflict with rust, so that it isn't installed: https://openqa.suse.de/tests/8913409#step/update_install/35

History

#1 Updated by mgrifalconi 2 months ago

  • Tags set to bugbusters
  • Target version set to QE-Core: Ready

#2 Updated by szarate about 2 months ago

  • Sprint set to QE-Core: June Sprint (Jun 08 - Jul 06)
  • Description updated (diff)

#3 Updated by szarate about 2 months ago

  • Status changed from New to Workable

#4 Updated by dvenkatachala about 2 months ago

  • Assignee set to dvenkatachala

#5 Updated by dvenkatachala about 2 months ago

Test failed to install rust with the conflict message the to be installed rust-1.60.0-150300.21.23.1.x86_64 requires 'rust1.60', but this requirement cannot be provided , even after dropped the installation of "rls" and "cargo".

I had raised the bug - https://bugzilla.suse.com/show_bug.cgi?id=1200499.

#6 Updated by dvenkatachala about 2 months ago

  • Status changed from Workable to In Progress

PR: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/15079 - Test skipped the installation of rls and cargo.

#7 Updated by szarate about 1 month ago

Hi!, can you provide an update of the current state of the ticket?

#8 Updated by dvenkatachala about 1 month ago

I have done the changes in script and raised a bug. Now I am waiting for latest run in the osd to close the ticket.

#9 Updated by szarate about 1 month ago

  • Sprint changed from QE-Core: June Sprint (Jun 08 - Jul 06) to QE-Core: July Sprint (Jul 06 - Aug 03)

#10 Updated by szarate 22 days ago

  • Status changed from In Progress to Resolved

this looks resolved :)

Also available in: Atom PDF