Project

General

Profile

action #112244

[qe-core] rust: cargo run --manifest-path testproject/Cargo.toml timed out

Added by dimstar 2 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
Start date:
2022-06-09
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

The command cargo run --manifest-path testproject/Cargo.toml keeps on timing out every now and then.
Sufficient reruns of the test happen to let it pass, sometimes it fails a few times in a row.

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-extra_tests_textmode@64bit fails in
rust

Test suite description

Maintainer: slindomansilla@suse.de.
Mainly post-installation console extra tests.

Reproducible

Fails since (at least) Build 20210920

Expected result

Last good: 20210920 (or more recent)

Further details

Always latest result in this scenario: latest

Suggestions

  1. add a timeout for cargo for 120s, as it depends on an externally available resource
  2. Create a ticket for follow up, to execute cargo run on a local project (see manorboy test)

History

#1 Updated by szarate 2 months ago

  • Sprint set to QE-Core: June Sprint (Jun 08 - Jul 06)
  • Tags set to bugbusters, qe-core-june-sprint
  • Subject changed from rust: cargo run --manifest-path testproject/Cargo.toml timed out to [qe-core] rust: cargo run --manifest-path testproject/Cargo.toml timed out
  • Description updated (diff)
  • Status changed from New to Workable
  • Target version set to QE-Core: Ready

#2 Updated by dvenkatachala 2 months ago

  • Assignee set to dvenkatachala

#3 Updated by dvenkatachala 2 months ago

  • Status changed from Workable to In Progress

#4 Updated by dvenkatachala 2 months ago

  • Status changed from In Progress to Resolved

Latest O3 run from update rust test:
Tumbleweed: https://openqa.opensuse.org/tests/2418489#step/rust/9

Also available in: Atom PDF