Project

General

Profile

action #111539

[sporadic] audit log comment test addition fails sometimes size:M

Added by okurz 3 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Concrete Bugs
Target version:
Start date:
2022-05-24
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

In https://app.circleci.com/pipelines/github/os-autoinst/openQA/9642/workflows/d48bcdfe-9b1e-47a1-bc80-53b05167be46/jobs/90997 but similarly in at least one pull request where I have seen this failing:

[10:44:52] t/ui/23-audit-log.t ........................ 21/? 
    #   Failed test 'right comment'
    #   at t/ui/23-audit-log.t line 140.
    #          got: 'Just a group test'
    #     expected: 'Just a job test'
    # Looks like you failed 1 test of 23.
[10:44:52] t/ui/23-audit-log.t ........................ 22/? 
#   Failed test 'clickable events'
#   at t/ui/23-audit-log.t line 141.
[10:44:52] t/ui/23-audit-log.t ........................ 23/? # Looks like you failed 1 test of 23.
                                                              [10:44:52] t/ui/23-audit-log.t ........................ Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/23 subtests

Acceptance criteria

  • AC1: The audit log test is stable

Suggestions

  • Check for inconsistent sorting or ambiguous CSS selectors
  • Check whether usage of wait_for_ajax can be improved/replaced

History

#1 Updated by mkittler 2 months ago

  • Subject changed from [sporadic] audit log comment test addition fails sometimes to [sporadic] audit log comment test addition fails sometimes size:M
  • Description updated (diff)
  • Status changed from New to Workable

#2 Updated by okurz 2 months ago

  • Status changed from Workable to In Progress
  • Assignee set to okurz

#3 Updated by okurz 2 months ago

Reproduced locally in 2/200 runs, that is a fail rate in this case of 1%. Maybe coverage analysis changes the ratio. My plan is to speedup the test first, then try to fix it and confirm stability.

#4 Updated by openqa_review 2 months ago

  • Due date set to 2022-06-09

Setting due date based on mean cycle time of SUSE QE Tools

#5 Updated by okurz 2 months ago

  • Status changed from In Progress to Feedback

#6 Updated by okurz 2 months ago

  • Due date deleted (2022-06-09)
  • Status changed from Feedback to Resolved

seems stable

Also available in: Atom PDF