Project

General

Profile

action #111290

Troubles upgrading os-autoinst on my SLE15-SP3 workstation

Added by pdostal about 1 month ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Support
Target version:
Start date:
2022-05-19
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Hello,

# grep PRETTY_NAME /etc/os-release 
PRETTY_NAME="SUSE Linux Enterprise Server 15 SP3"
# zypper dup
Refreshing service 'Basesystem_Module_15_SP3_x86_64'.
Refreshing service 'Containers_Module_15_SP3_x86_64'.
Refreshing service 'Desktop_Applications_Module_15_SP3_x86_64'.
Refreshing service 'Development_Tools_Module_15_SP3_x86_64'.
Refreshing service 'Public_Cloud_Module_15_SP3_x86_64'.
Refreshing service 'SUSE_Linux_Enterprise_Server_15_SP3_x86_64'.
Refreshing service 'SUSE_Package_Hub_15_SP3_x86_64'.
Refreshing service 'Server_Applications_Module_15_SP3_x86_64'.
Refreshing service 'Web_and_Scripting_Module_15_SP3_x86_64'.
Loading repository data...
Reading installed packages...
Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
Computing distribution upgrade...

Problem: nothing provides 'libopencv_core.so.3.3()(64bit)' needed by the to be installed os-autoinst-4.6.1606482144.ab6cdfe2-bp153.1.1.x86_64
 Solution 1: Following actions will be done:
  deinstallation of os-autoinst-4.6.1632480495.3a7089c4-bp152.857.1.x86_64
  deinstallation of openQA-worker-4.6.1624280432.2ce59c621-bp153.2.3.3.noarch
  deinstallation of os-autoinst-openvswitch-4.6.1606482144.ab6cdfe2-bp153.2.6.1.x86_64
 Solution 2: keep obsolete os-autoinst-4.6.1632480495.3a7089c4-bp152.857.1.x86_64
 Solution 3: break os-autoinst-4.6.1606482144.ab6cdfe2-bp153.1.1.x86_64 by ignoring some of its dependencies

Can you please suggest what is wrong with my setup?

History

#1 Updated by okurz about 1 month ago

  • Category changed from Concrete Bugs to Support
  • Status changed from New to In Progress
  • Assignee set to okurz
  • Target version set to Ready

Well, we commonly support only Tumbleweed and Leap but 15.3 and SLE 15-SP3 are not too far off. I suspect a missing repo devel:openQA:SLE:15 ifcwe even have that. But you can use the corresponding Leap one. Can you please list your zypper lr --uri

#2 Updated by pdostal about 1 month ago

  • Status changed from In Progress to Resolved

Hello Oliver,

I have the devel:openQA:SLE:15 repository in my system.
The only problem was that the repository was disabled :)

However after upgrade I run on another issue with some opencv object missing.
If the SLE isn't supported I should probably switch to Leap then.

Also available in: Atom PDF