Project

General

Profile

action #109779

coordination #91646: [saga][epic] SUSE Maintenance QA workflows with fully automated testing, approval and release

Cannot approve incident due to test report parsing error

Added by jbaier_cz 3 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
High
Assignee:
Target version:
Start date:
2022-04-11
Due date:
% Done:

0%

Estimated time:

Description

Observation

mtui-auto> approve
info: Approve request: 269328
Traceback (most recent call last):
  File "/usr/bin/osc", line 45, in <module>
    r = babysitter.run(osccli)
  File "/usr/lib/python3.8/site-packages/osc/babysitter.py", line 67, in run
    return prg.main(argv)
  File "/usr/lib/python3.8/site-packages/osc/cmdln.py", line 347, in main
    return self.cmd(args)
  File "/usr/lib/python3.8/site-packages/osc/cmdln.py", line 370, in cmd
    retval = self.onecmd(argv)
  File "/usr/lib/python3.8/site-packages/osc/cmdln.py", line 504, in onecmd
    return self._dispatch_cmd(handler, argv)
  File "/usr/lib/python3.8/site-packages/osc/cmdln.py", line 1235, in _dispatch_cmd
    return handler(argv[0], opts, *args)
  File "/usr/lib/osc-plugins/qam.py", line 615, in do_qam
    ret = interp.onecmd(sys.argv[index + 1:])
  File "/usr/lib/python3.8/site-packages/osc/cmdln.py", line 504, in onecmd
    return self._dispatch_cmd(handler, argv)
  File "/usr/lib/python3.8/site-packages/osc/cmdln.py", line 1235, in _dispatch_cmd
    return handler(argv[0], opts, *args)
  File "/usr/lib/osc-plugins/qam.py", line 125, in do_approve
    action()
  File "/usr/lib/python3.8/site-packages/oscqam/actions.py", line 76, in __call__
    return self.action(*args, **kwargs)
  File "/usr/lib/python3.8/site-packages/oscqam/actions.py", line 637, in action
    self.validate()
  File "/usr/lib/python3.8/site-packages/oscqam/actions.py", line 630, in validate
    self.template.passed()
  File "/usr/lib/python3.8/site-packages/oscqam/models.py", line 879, in passed
    if self.status != Template.STATUS_SUCCESS:
  File "/usr/lib/python3.8/site-packages/oscqam/models.py", line 897, in status
    summary = self.log_entries["SUMMARY"]
KeyError: 'SUMMARY'
error: Approve failed: Command '['osc', '-A', 'https://api.suse.de', 'qam', 'approve', '269328']' returned non-zero exit status 1.

The issue is caused by oscqam fetching the fancy formatted (a.k.a. human-readable) report.

Currently, the qam.suse.de/testreport/.*/log is redirected to qam2.suse.de/reports/\1/log, the raw report can still be found on qam2.suse.de/testreports/\1/log.

Acceptance criteria

  • incidents can be approved
  • links reported by the tooling points to human readable reports

Mitigation

The problem with approving was mitigated by disabling the corresponding rewrite in the Apache on qam.suse.de

Rollback steps

  • enable Apache rewrite

Related issues

Related to QA - action #104781: Getting familiar with oscqam pluginNew2022-01-10

History

#1 Updated by jbaier_cz 3 months ago

As the issue was already mitigated, it is not urgent anymore.

I created https://gitlab.suse.de/qa-maintenance/qam-oscplugin/-/merge_requests/17 which is probably the fastest and easiest way around this problem (at least for now).

#2 Updated by jbaier_cz 3 months ago

  • Related to action #104781: Getting familiar with oscqam plugin added

#3 Updated by jbaier_cz 3 months ago

  • Status changed from New to Feedback
  • Assignee set to jbaier_cz
  • Target version set to Ready

#4 Updated by okurz 3 months ago

  • Tags set to reactive work

#5 Updated by osukup 3 months ago

osc-qam-plugin 0.41.0 released

#6 Updated by okurz 3 months ago

  • Tags deleted (reactive work)
  • Parent task set to #91646

#7 Updated by okurz 2 months ago

We discussed in the weekly unblock. We couldn't understand how to reproduce, how to check for success or anything. I am assuming the issue is fixed by the mentioned release and the rollback of Apache config should be done.

jbaier_cz can you please check that and resolve

#8 Updated by jbaier_cz about 2 months ago

The fix was released at the same day the issue was spotted. The tricky part was to give sufficient time for users to upgrade. I believe almost 3 weeks are enough. I will rollback the Apache changes and we will see how many users will be affected. For those, osc-plugin-qam >= 0.41 needs to be installed.

#9 Updated by jbaier_cz about 2 months ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF