Project

General

Profile

action #108803

Fix key navigation in yast2 snapper ncurses test

Added by geor 3 months ago. Updated 3 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Target version:
Start date:
2022-03-23
Due date:
% Done:

0%

Estimated time:

Description

Motivation

Module yast2_snapper_ncurses.pm fails because the snapshot is never highlighted, as can be seen here: https://openqa.suse.de/tests/8368512#step/yast2_snapper_ncurses/77
This is due to send_key_until_needlematch's key pgdn no navigating as intended.

Acceptance criteria

AC1: Manually check which key to highlight the snapshot with. If pgdn no longer works, investigate whether this is intended.
AC2: Adjust send_key_until_needlematch of sub y2snapper_new_snapshot so that the newly created snapshot is highlighted.

History

#1 Updated by geor 3 months ago

  • Description updated (diff)

#2 Updated by geor 3 months ago

  • Description updated (diff)

#3 Updated by JERiveraMoya 3 months ago

  • Tags deleted (qe-yast-refinement)
  • Status changed from New to Rejected

Let's reject this one then, thanks for the quick fix in:
https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/14602

Also available in: Atom PDF