Project

General

Profile

action #107395

[HPC] zypper returns error code 107 in slurm_master

Added by ybonatakis 4 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
QE Kernel - QE Kernel Current
Start date:
2022-02-23
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

(4/6) Installing: twopence-0.4.2-3.d_t.22.x86_64 [.
warning: /var/cache/zypp/packages/devel_tools/x86_64/twopence-0.4.2-3.d_t.22.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID 498d5a23: NOKEY
.....
/usr/lib/tmpfiles.d/net-snmp.conf:1: Line references path below legacy directory /var/run/, updating /var/run/net-snmp → /run/net-snmp; please update the tmpfiles.d/ drop-in file accordingly.
/usr/lib/tmpfiles.d/systemd.conf:19: Failed to resolve user 'systemd-network': No such process
/usr/lib/tmpfiles.d/systemd.conf:20: Failed to resolve user 'systemd-network': No such process
/usr/lib/tmpfiles.d/systemd.conf:21: Failed to resolve user 'systemd-network': No such process
/usr/lib/tmpfiles.d/systemd.conf:22: Failed to resolve user 'systemd-network': No such process
warning: %post(twopence-0.4.2-3.d_t.22.x86_64) scriptlet failed, exit status 65
done]
(5/6) Installing: libtwopence0-0.4.2-3.d_t.22.x86_64 [.
warning: /var/cache/zypp/packages/devel_tools/x86_64/libtwopence0-0.4.2-3.d_t.22.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID 498d5a23: NOKEY
......done]
(6/6) Installing: twopence-shell-client-0.4.2-3.d_t.22.x86_64 [.
warning: /var/cache/zypp/packages/devel_tools/x86_64/twopence-shell-client-0.4.2-3.d_t.22.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID 498d5a23: NOKEY
.......done]
n3BEE-107-

107 - ZYPPER_EXIT_INF_RPM_SCRIPT_FAILED means "Installation basically succeeded, but some of the packages %post install scripts returned an error"

openQA test in scenario sle-15-SP4-Online-x86_64-hpc_EPSILON_slurm_master@64bit fails in
slurm_master

Test suite description

HPC cluster for experimental and fast-moving external tests. maintainer: schlad@suse.de

Reproducible

Fails since (at least) Build 99.1

Expected result

Last good: 98.1 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by ybonatakis 4 months ago

  • Target version set to QE Kernel Current

#2 Updated by ybonatakis 4 months ago

https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/14341 provides a workaround, excluding the error code which cause the failure and let the test continue

#3 Updated by ybonatakis 4 months ago

  • Status changed from In Progress to Resolved

As per https://openqa.suse.de/tests/8224810 problem is resolved on openqa side. Although the issue needs to checked out with package maintainer to fix the spec

Also available in: Atom PDF