Project

General

Profile

action #107347

[qe-core] test fails in system_role

Added by tjyrinki_suse 4 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-15-SP4-Online-x86_64-textmode+role_xen@64bit fails in
system_role

Test suite description

Maintainer: QE Core

Selects Xen role in System Role window (12SP2+). Select bigger HDD size to resemble more realistic scenario: More place for virtual machines. This is also necessary to enable snapshots based on the installer logic. Related progress issues: https://progress.opensuse.org/issues/30853

Renamed from textmode+xen_server_role

Reproducible

Fails since (at least) Build 91.2

Expected result

Last good: 88.4 (or more recent)

Further details

Always latest result in this scenario: latest

Acceptance Criteria

AC1: Make the Xen selection work again, a wrong needle was created?

History

#1 Updated by tjyrinki_suse 4 months ago

  • Description updated (diff)
  • Status changed from New to Workable
  • Priority changed from Normal to High

#2 Updated by tjyrinki_suse 4 months ago

  • Assignee set to tjyrinki_suse

#3 Updated by tjyrinki_suse 4 months ago

  • Status changed from Workable to In Progress

#4 Updated by tjyrinki_suse 4 months ago

The created needle system_role-system-role-xen-20220222 seems wrong as Xen is not selected in it. However, https://openqa.suse.de/tests/8089629#step/system_role/1 shows it was indeed failing before that, and there were a bunch of related needle changes like now recognized system_role-before-role-selection-20220125.png after it last passed in https://openqa.suse.de/tests/8030295#step/system_role/1

#5 Updated by dzedro 4 months ago

tjyrinki_suse wrote:

The created needle system_role-system-role-xen-20220222 seems wrong as Xen is not selected in it. However, https://openqa.suse.de/tests/8089629#step/system_role/1 shows it was indeed failing before that, and there were a bunch of related needle changes like now recognized system_role-before-role-selection-20220125.png after it last passed in https://openqa.suse.de/tests/8030295#step/system_role/1

You are right, the needle is "wrong" because it contains two areas.
I would not add anything else than the expected system role, the description of it can always change or it will be different in few pixels.
The test is clicking on that field and selecting the role.
With multiple roles you have to specify where to click so the click will select the role.
I added the click area on that needle.

#6 Updated by tjyrinki_suse 4 months ago

  • Status changed from In Progress to Resolved

Fixed in https://openqa.suse.de/tests/8272053 !

So system_role test changed, a click area was missing from system_role-system-role-xen-20220222 and also system-role-xen-selected-20220304 was created.

Also available in: Atom PDF