Project

General

Profile

Actions

action #106470

closed

Selenium's `send_keys` function broken as of ChromeDriver 98.0.4758.80

Added by mkittler about 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Regressions/Crashes
Target version:
Start date:
2022-02-09
Due date:
% Done:

0%

Estimated time:

Description

Since some of openQA's Selenium-based tests are affected┬╣ I've been creating this ticket to keep track of the supposedly upstream bug in ChromeDriver 98.0.4758.80. The relevant upstream ticket is https://bugs.chromium.org/p/chromedriver/issues/detail?id=3999 and the problem is mentioned in comments on https://bugs.chromium.org/p/chromedriver/issues/detail?id=2269.

One can easily workaround the issue via

sudo zypper in --oldpackage http://download.opensuse.org/history/20220206/tumbleweed/repo/oss/x86_64/chromedriver-97.0.4692.99-1.1.x86_64.rpm http://download.opensuse.org/history/20220206/tumbleweed/repo/oss/x86_64/chromium-97.0.4692.99-1.1.x86_64.rpm

and the CI is not affected yet as well.

If the problem isn't fixed by upstream soon we can consider implementing a workaround on our side. I've already created one for the fullstack tests as it simplifies the code there anyways (see https://github.com/os-autoinst/openQA/pull/4499/commits/bf611dd47b52e9a73f67f9cdfc968ba8c495cb25). We could do the same for other tests (using the JavaScript DOM API to set the form element value directly).


┬╣ The error is: sendKeysToElement: unknown error: Cannot construct KeyEvent from non-typeable key

Actions #1

Updated by mkittler about 2 years ago

  • Description updated (diff)
Actions #2

Updated by okurz about 2 years ago

https://bugs.chromium.org/p/chromedriver/issues/detail?id=2269 is from 2018 (!) so I assume that at least that won't be fixed that soon

Actions #3

Updated by okurz about 2 years ago

  • Category set to Regressions/Crashes
Actions #4

Updated by mkittler about 2 years ago

  • Description updated (diff)
  • Category deleted (Regressions/Crashes)

But the last comments mentioned in that ticket are quite recent. So while the ticket itself might not be relevant the discussion in it is. It looks like https://bugs.chromium.org/p/chromedriver/issues/detail?id=3999 is the relevant ticket. I've been updating the ticket description.

Actions #5

Updated by mkittler about 2 years ago

  • Category set to Regressions/Crashes
Actions #6

Updated by mkittler about 2 years ago

Apparently 98.0.4758.102 will fix it so I'll refrain from investing time in workarounds for now.

Actions #7

Updated by mkittler about 2 years ago

  • Status changed from Feedback to Resolved

The latest chromedriver is in TW and works indeed.

Actions

Also available in: Atom PDF