Project

General

Profile

action #105867

OpenQA bot schedules jobs with incomplete INCIDENT_REPO

Added by MDoucha 5 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Target version:
Start date:
2022-02-03
Due date:
% Done:

0%

Estimated time:

Description

This week, the OpenQA bot has been scheduling kernel tests without adding the Basesystem/LTSS repository to INCIDENT_REPO. Only the livepatching repository was added. This happened on SLE-12SP4, SLE-15SP2 (twice) and SLE-15SP1:

INCIDENT_REPO=http://download.suse.de/ibs/SUSE:/Maintenance:/22660/SUSE_Updates_SLE-Module-Live-Patching_15-SP1_x86_64

Some of these tests have already been rescheduled with the correct settings but SLE-15SP1 is still affected. Current S:M:22660 incident data in QEM dashboard API:

{"approved":false,"channels":["SUSE:SLE-15-SP1:Update","SUSE:Updates:SLE-Product-HA:15-SP1:x86_64","SUSE:Updates:SLE-Product-HA:15-SP1:s390x","SUSE:Updates:SLE-Product-HA:15-SP1:ppc64le","SUSE:Updates:SLE-Product-HA:15-SP1:aarch64","SUSE:Updates:Storage:6:aarch64","SUSE:Updates:Storage:6:x86_64","SUSE:Updates:SLE-Module-Development-Tools-OBS:15-SP3:x86_64","SUSE:Updates:SLE-Module-Development-Tools-OBS:15-SP3:s390x","SUSE:Updates:SLE-Module-Development-Tools-OBS:15-SP3:ppc64le","SUSE:Updates:SLE-Module-Development-Tools-OBS:15-SP3:aarch64","SUSE:Updates:SLE-Module-Live-Patching:15-SP1:x86_64","SUSE:Updates:SLE-Module-Live-Patching:15-SP1:ppc64le","SUSE:Updates:SUSE-CAASP:4.0:x86_64","SUSE:Updates:SLE-Product-SLES:15-SP1-BCL:x86_64","SUSE:Updates:SLE-Product-HPC:15-SP1-ESPOS:aarch64","SUSE:Updates:SLE-Product-HPC:15-SP1-ESPOS:x86_64","SUSE:Updates:SLE-Product-SLES_SAP:15-SP1:ppc64le","SUSE:Updates:SLE-Product-SLES_SAP:15-SP1:x86_64","SUSE:Updates:SLE-Product-SLES:15-SP1-LTSS:x86_64","SUSE:Updates:SLE-Product-SLES:15-SP1-LTSS:s390x","SUSE:Updates:SLE-Product-SLES:15-SP1-LTSS:ppc64le","SUSE:Updates:SLE-Product-SLES:15-SP1-LTSS:aarch64","SUSE:Updates:SLE-Product-HPC:15-SP1-LTSS:x86_64","SUSE:Updates:SLE-Product-HPC:15-SP1-LTSS:aarch64","SUSE:Updates:openSUSE-SLE:15.3","SUSE:Updates:openSUSE-SLE:15.4","SUSE:Updates:SLE-Module-Development-Tools-OBS:15-SP4:aarch64","SUSE:Updates:SLE-Module-Development-Tools-OBS:15-SP4:ppc64le","SUSE:Updates:SLE-Module-Development-Tools-OBS:15-SP4:s390x","SUSE:Updates:SLE-Module-Development-Tools-OBS:15-SP4:x86_64"],"emu":false,"inReview":false,"inReviewQAM":false,"isActive":true,"number":22660,"packages":["dtb-aarch64","kernel-debug","kernel-default","kernel-docs","kernel-kvmsmall","kernel-livepatch-SLE15-SP1_Update_28","kernel-obs-build","kernel-obs-qa","kernel-source","kernel-syms","kernel-vanilla","kernel-zfcpdump"],"project":"SUSE:Maintenance:22660","rr_number":null}
smelt-22660.png (183 KB) smelt-22660.png S:M:22660 repository info in SMELT MDoucha, 2022-02-03 10:20
12492

History

#1 Updated by okurz 5 months ago

  • Target version set to future

#2 Updated by osukup 4 months ago

.. caused by mismatch of data between OBS - SMELT + wrong setup of channels

for kernel we can add workaround which checks if Kernel jobs other than LTSS contains OS_TEST_ISSUES and reject schedule if not with ERROR in log.

#3 Updated by cdywan 4 months ago

osukup wrote:

.. caused by mismatch of data between OBS - SMELT + wrong setup of channels

for kernel we can add workaround which checks if Kernel jobs other than LTSS contains OS_TEST_ISSUES and reject schedule if not with ERROR in log.

So this might be a straightforward fix? I suggest we estimate this tomorrow morning to clarify the impact.

#4 Updated by osukup 4 months ago

cdywan wrote:

osukup wrote:

.. caused by mismatch of data between OBS - SMELT + wrong setup of channels

for kernel we can add workaround which checks if Kernel jobs other than LTSS contains OS_TEST_ISSUES and reject schedule if not with ERROR in log.

So this might be a straightforward fix? I suggest we estimate this tomorrow morning to clarify the impact.

no, there isn't a possible straightforward fix, only a workaround ...

#5 Updated by cdywan 4 months ago

  • Assignee deleted (osukup)

osukup wrote:

no, there isn't a possible straightforward fix, only a workaround ...

We can estimate it tomorrow if you think it's worth putting on the backlog

#6 Updated by osukup 3 months ago

  • Status changed from New to Resolved

kernel jobs now wont be scheduled without product repo -> https://github.com/openSUSE/qem-bot/pull/5

Also available in: Atom PDF