Project

General

Profile

action #103467

[sporadic] os-autoinst: 14-isotovideo.t:133 'no fatal error recorded' size:M

Added by tinita about 2 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Concrete Bugs
Target version:
Start date:
2021-11-30
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

https://github.com/os-autoinst/os-autoinst/runs/4408519079?check_suite_focus=true#step:3:579
https://github.com/perlpunk/os-autoinst/runs/4408870749?check_suite_focus=true#step:3:577

8:     #   Failed test 'no fatal error recorded'
8:     #   at ./14-isotovideo.t line 133.
8:     # Looks like you failed 1 test of 5.
8: 
8: #   Failed test 'upload assets on demand even in failed jobs'
8: #   at ./14-isotovideo.t line 134.
8: {"component":"backend","msg":"myjsonrpc: remote end terminated connection, stopping at \/opt\/myjsonrpc.pm line 43."} at ./14-isotovideo.t line 133.
8: # Tests were run but no plan was declared and done_testing() was not seen.
8: # Looks like your test exited with 1 just after 8.
8: [14:06:10] ./14-isotovideo.t ........................ 
8: Dubious, test returned 1 (wstat 256, 0x100)
8: Failed 1/8 subtests 

Acceptance criteria

  • AC1: 14-isotovideo.t passes 20 times w/o failures

Suggestions

  • Confirm when it started failing

Related issues

Copied from openQA Project - action #103422: [sporadic] os-autoinst: 13-osutils.t:167 Failed test 'Exit code appear in log' in GHA size:MResolved2021-11-30

History

#1 Updated by tinita about 2 months ago

  • Copied from action #103422: [sporadic] os-autoinst: 13-osutils.t:167 Failed test 'Exit code appear in log' in GHA size:M added

#2 Updated by tinita about 2 months ago

  • Subject changed from [sporadic] os-autoinst: 14-isotovideo.t:133 to [sporadic] os-autoinst: 14-isotovideo.t:133 'no fatal error recorded'
  • Description updated (diff)

#3 Updated by tinita about 2 months ago

  • Description updated (diff)

#4 Updated by cdywan about 2 months ago

  • Subject changed from [sporadic] os-autoinst: 14-isotovideo.t:133 'no fatal error recorded' to [sporadic] os-autoinst: 14-isotovideo.t:133 'no fatal error recorded' size:M
  • Status changed from New to Workable

#5 Updated by tinita about 2 months ago

I went back until "Merge pull request #1825 from perlpunk/check-for-git-status"
https://github.com/os-autoinst/os-autoinst/runs/4035778918?check_suite_focus=true (Oct 28)
(looking into passed CI runs because of the bug I introduced with CheckGitStatus).
I looked into all master CI runs and could not find any other occurrence of this error.

#6 Updated by mkittler about 2 months ago

  • Assignee set to mkittler

#7 Updated by mkittler about 2 months ago

The exact same error is easily reproducible by running the test locally in a loop (it didn't take long) when using the currently broken version of RWP. To cross-check I've did the same but using the last good version of RWP and passed so far. I'll have to conduce a few more runs to be sure, though.

#8 Updated by mkittler about 2 months ago

I suppose I could only ran into an error because I ran the tests in parallel (against different RWP versions). When only running one test at a time I couldn't see any issues so far locally (also not on the broken RWP version).

It also looks like

{"component":"backend","msg":"myjsonrpc: remote end terminated connection, stopping at \/opt\/myjsonrpc.pm line 43."} at ./14-isotovideo.t line 133.

is printed in different error cases and the failures I had when running tests in parallel were actually a bit different (despite also concluding with that error message).

#9 Updated by mkittler about 1 month ago

  • Status changed from Workable to Resolved

I couldn't reproduce the issue locally and we haven't seen the problem in the CI for a while. So I'm closing the ticket. (We can reopen it when we encounter the problem again.)

I've also checked whether the check depends on a very short timeout but that's not the case. With the little log we have it is really hard to tell what's the problem except that it is happening likely at the very end of isotovideo's execution because the previous checks pass.

Also available in: Atom PDF