Project

General

Profile

action #103029

Fix problems with os-autoinst's thread creation and the latest TBB version

Added by mkittler 2 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
Concrete Bugs
Target version:
Start date:
2021-11-25
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

observation

With the latest TBB version from Factory (libtbb12-2021.4.0-1.1.x86_64.rpm) the signalblocker test might hang which we've observed multiple times in OBS builds. This is reproducible on TW by installing the latest TBB library and the latest OpenCV library (libopencv4_5-4.5.2-2.3.x86_64.rpm) from Factory:

OS_AUTOINST_TEST_THREAD_COUNT=20 os-autoinst-test t/28-signalblocker.t 
Build directory: /hdd/openqa-devel/build/os-autoinst-ninja
[1/2] cd /hdd/openqa-devel/repos/os-autoinst && /hdd/openqa-devel/repos/os-autoinst/tools/invoke-tests --prove-tool /usr/bin/prove --make-tool /usr/bin/ninja --build-directory /hdd/openqa-devel/build/os-autoinst-ninja
t/28-signalblocker.t .. 
ok 1 - initially one thread
# Blocking SIGCHLD and SIGTERM
# threads used: 20 of 8
TBB Warning: The number of workers is currently limited to 7. The request for 19 workers is ignored. Further requests for more workers will be silently ignored until the limit changes.

acceptance criteria

  • AC1: Tests do no longer deadlock (using TBB from Factory).
  • AC2: The thread creation in autotest/driver does not deadlock (using TBB from Factory).

further notes

  • There hasn't been an update of OpenCV so TBB seems to be the changing part here. The new version of OpenCV is only required because TBB changed the soname and therefore OpenCV needs to be rebuilt to use the new TBB library.
  • Draft PR: https://github.com/os-autoinst/os-autoinst/pull/1860

History

#1 Updated by mkittler 2 months ago

  • Status changed from In Progress to Feedback

The PR has been merged: https://github.com/os-autoinst/os-autoinst/pull/1860

Let's see whether the problem disappears (e.g. https://build.opensuse.org/packages/os-autoinst/job_history/devel:openQA/openSUSE_Factory/x86_64). It doesn't happen always - only if the OBS VM has too few cores.

#2 Updated by mkittler about 2 months ago

  • Status changed from Feedback to Resolved

#3 Updated by okurz about 2 months ago

  • Project changed from qam-qasle-collaboration to openQA Project
  • Category set to Concrete Bugs

Also available in: Atom PDF