Project

General

Profile

action #101779

osd deployment failed with non-zero status openqa-worker5

Added by osukup 3 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Concrete Bugs
Target version:
Start date:
2021-11-01
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

zypper reports needing reboot so non zero status ( 10x are informal, safely can be considered as zero)

https://gitlab.suse.de/openqa/osd-deployment/-/jobs/669420

https://gitlab.suse.de/openqa/osd-deployment/-/blob/master/.gitlab-ci.yml#L188

History

#1 Updated by osukup 3 months ago

  • Description updated (diff)

#2 Updated by tinita 3 months ago

  • Category set to Concrete Bugs
  • Priority changed from Normal to High
  • Target version set to Ready

#3 Updated by osukup 3 months ago

  • Description updated (diff)

#4 Updated by mkittler 3 months ago

  • Assignee set to mkittler

#5 Updated by mkittler 3 months ago

Not sure whether it is really the reboot message leading to a non-zero exit status. There's also a checksum error concerning arm-4 and arm-5:

openqaworker-arm-5.qa.suse.de:
    Loading repository data...
    Reading installed packages...
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
    Computing distribution upgrade...

    The following 45 packages are going to be upgraded:
      elfutils elfutils-lang kernel-firmware-all kernel-firmware-amdgpu kernel-firmware-ath10k kernel-firmware-ath11k kernel-firmware-atheros kernel-firmware-bluetooth kernel-firmware-bnx2 kernel-firmware-brcm kernel-firmware-chelsio kernel-firmware-dpaa2 kernel-firmware-i915 kernel-firmware-intel kernel-firmware-iwlwifi kernel-firmware-liquidio kernel-firmware-marvell kernel-firmware-media kernel-firmware-mediatek kernel-firmware-mellanox kernel-firmware-mwifiex kernel-firmware-network kernel-firmware-nfp kernel-firmware-nvidia kernel-firmware-platform kernel-firmware-prestera kernel-firmware-qlogic kernel-firmware-radeon kernel-firmware-realtek kernel-firmware-serial kernel-firmware-sound kernel-firmware-ti kernel-firmware-ueagle kernel-firmware-usb-network libasm1 libdw1 libebl-plugins libelf1 openQA-client openQA-common openQA-worker os-autoinst os-autoinst-distri-opensuse-deps os-autoinst-openvswitch suse-module-tools

    The following 39 packages are going to change vendor:
    elfutils                   
      SUSE LLC <https://www.suse.com/> -> obs://build.opensuse.org/Kernel
    elfutils-lang              
      SUSE LLC <https://www.suse.com/> -> obs://build.opensuse.org/Kernel
    kernel-firmware-all        
      SUSE LLC <https://www.suse.com/> -> obs://build.opensuse.org/Kernel
    kernel-firmware-amdgpu     
      SUSE LLC <https://www.suse.com/> -> obs://build.opensuse.org/Kernel
    kernel-firmware-ath10k     
      SUSE LLC <https://www.suse.com/> -> obs://build.opensuse.org/Kernel
    kernel-firmware-ath11k     
      SUSE LLC <https://www.suse.com/> -> obs://build.opensuse.org/Kernel
    kernel-firmware-atheros    
      SUSE LLC <https://www.suse.com/> -> obs://build.opensuse.org/Kernel
    kernel-firmware-bluetooth  
      SUSE LLC <https://www.suse.com/> -> obs://build.opensuse.org/Kernel
    kernel-firmware-bnx2       
      SUSE LLC <https://www.suse.com/> -> obs://build.opensuse.org/Kernel
    kernel-firmware-brcm       
      SUSE LLC <https://www.suse.com/> -> obs://build.opensuse.org/Kernel
    kernel-firmware-chelsio    
      SUSE LLC <https://www.suse.com/> -> obs://build.opensuse.org/Kernel
    kernel-firmware-dpaa2      
      SUSE LLC <https://www.suse.com/> -> obs://build.opensuse.org/Kernel
    kernel-firmware-i915       
      SUSE LLC <https://www.suse.com/> -> obs://build.opensuse.org/Kernel
    kernel-firmware-intel      
      SUSE LLC <https://www.suse.com/> -> obs://build.opensuse.org/Kernel
    kernel-firmware-iwlwifi    
      SUSE LLC <https://www.suse.com/> -> obs://build.opensuse.org/Kernel
    kernel-firmware-liquidio   
      SUSE LLC <https://www.suse.com/> -> obs://build.opensuse.org/Kernel
    kernel-firmware-marvell    
      SUSE LLC <https://www.suse.com/> -> obs://build.opensuse.org/Kernel
    kernel-firmware-media      
      SUSE LLC <https://www.suse.com/> -> obs://build.opensuse.org/Kernel
    kernel-firmware-mediatek   
      SUSE LLC <https://www.suse.com/> -> obs://build.opensuse.org/Kernel
    kernel-firmware-mellanox   
      SUSE LLC <https://www.suse.com/> -> obs://build.opensuse.org/Kernel
    kernel-firmware-mwifiex    
      SUSE LLC <https://www.suse.com/> -> obs://build.opensuse.org/Kernel
    kernel-firmware-network    
      SUSE LLC <https://www.suse.com/> -> obs://build.opensuse.org/Kernel
    kernel-firmware-nfp        
      SUSE LLC <https://www.suse.com/> -> obs://build.opensuse.org/Kernel
    kernel-firmware-nvidia     
      SUSE LLC <https://www.suse.com/> -> obs://build.opensuse.org/Kernel
    kernel-firmware-platform   
      SUSE LLC <https://www.suse.com/> -> obs://build.opensuse.org/Kernel
    kernel-firmware-prestera   
      SUSE LLC <https://www.suse.com/> -> obs://build.opensuse.org/Kernel
    kernel-firmware-qlogic     
      SUSE LLC <https://www.suse.com/> -> obs://build.opensuse.org/Kernel
    kernel-firmware-radeon     
      SUSE LLC <https://www.suse.com/> -> obs://build.opensuse.org/Kernel
    kernel-firmware-realtek    
      SUSE LLC <https://www.suse.com/> -> obs://build.opensuse.org/Kernel
    kernel-firmware-serial     
      SUSE LLC <https://www.suse.com/> -> obs://build.opensuse.org/Kernel
    kernel-firmware-sound      
      SUSE LLC <https://www.suse.com/> -> obs://build.opensuse.org/Kernel
    kernel-firmware-ti         
      SUSE LLC <https://www.suse.com/> -> obs://build.opensuse.org/Kernel
    kernel-firmware-ueagle     
      SUSE LLC <https://www.suse.com/> -> obs://build.opensuse.org/Kernel
    kernel-firmware-usb-network
      SUSE LLC <https://www.suse.com/> -> obs://build.opensuse.org/Kernel
    libasm1                    
      SUSE LLC <https://www.suse.com/> -> obs://build.opensuse.org/Kernel
    libdw1                     
      SUSE LLC <https://www.suse.com/> -> obs://build.opensuse.org/Kernel
    libebl-plugins             
      SUSE LLC <https://www.suse.com/> -> obs://build.opensuse.org/Kernel
    libelf1                    
      SUSE LLC <https://www.suse.com/> -> obs://build.opensuse.org/Kernel
    suse-module-tools          
      SUSE LLC <https://www.suse.com/> -> obs://build.opensuse.org/Kernel

    The following 2 NEW packages are going to be installed:
      kernel-firmware-qcom systemd-rpm-macros

    45 packages to upgrade, 2 new, 39  to change vendor.
    Overall download size: 265.1 MiB. Already cached: 1.5 MiB. After the operation, additional 49.9 MiB will be used.
    Continue? [y/n/v/...? shows all options] (y): y
    In cache os-autoinst-4.6.1635528942.6ef9b3e4-lp153.916.1.aarch64.rpm (1/47), 301.6 KiB (950.0 KiB unpacked)
    In cache os-autoinst-openvswitch-4.6.1635528942.6ef9b3e4-lp153.916.1.aarch64.rpm (2/47),  98.4 KiB (  9.4 KiB unpacked)
    In cache os-autoinst-distri-opensuse-deps-1.1635735876.fd222d4ec-lp153.8589.1.noarch.rpm (3/47),   8.2 KiB (    0   B unpacked)
    In cache openQA-common-4.6.1635525801.1df7a829f-lp153.4524.1.noarch.rpm (4/47), 400.9 KiB (345.9 KiB unpacked)
    In cache openQA-client-4.6.1635525801.1df7a829f-lp153.4524.1.noarch.rpm (5/47), 326.5 KiB ( 51.7 KiB unpacked)
    In cache openQA-worker-4.6.1635525801.1df7a829f-lp153.4524.1.noarch.rpm (6/47), 358.2 KiB (145.3 KiB unpacked)
    Retrieving package kernel-firmware-qcom-20210928-lp153.2.1.noarch (7/47),  13.5 MiB ( 13.5 MiB unpacked)
    Retrieving: kernel-firmware-qcom-20210928-lp153.2.1.noarch.rpm [............................done (1.0 MiB/s)]

    Warning: Digest verification failed for file 'kernel-firmware-qcom-20210928-lp153.2.1.noarch.rpm'
    [/var/tmp/AP_0xKX9ghL/noarch/kernel-firmware-qcom-20210928-lp153.2.1.noarch.rpm]

      expected 7de677d54e615dd5db87f00c16d46f98f8a25b94ed38263bc77317ee6fa4aa93
      but got  42ab51bd8ad475060f328b7927b71a005304c3de70b1bed2e387afbfde298c86

    Accepting packages with wrong checksums can lead to a corrupted system and in extreme cases even to a system compromise.

    However if you made certain that the file with checksum '42ab..' is secure, correct
    and should be used within this operation, enter the first 4 characters of the checksum
    to unblock using this file on your own risk. Empty input will discard the file.

    Unblock or discard? [42ab/...? shows all options] (discard): discard
    Package kernel-firmware-qcom-20210928-lp153.2.1.noarch (kernel_stable) seems to be corrupted during transfer. Do you want to retry retrieval?
    Abort, retry, ignore? [a/r/i] (a): a
    Problem occurred during or after installation or removal of packages:
    Installation has been aborted as directed.
    Please see the above error message for a hint.

It looks like the issue is caused by using a different kernel repository. Likely kraih configured it as part of #101271.

#6 Updated by mkittler 3 months ago

  • Status changed from New to Resolved

The problem should be fixed by #101271#note-5. The retried deployment job passed now. Any other problems related with the arm-4 and 5 kernel switch should better be handled in #101271.

Also available in: Atom PDF