Project

General

Profile

action #100850

Chromedriver crashes in openQA's CI

Added by mkittler about 2 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
Concrete Bugs
Target version:
Start date:
2021-10-12
Due date:
2022-01-31
% Done:

0%

Estimated time:
Difficulty:

Description

observation

Chromedriver crashes on multiple PRs and looks unrelated to changes in these PRs:

[18:23:14] t/full-stack.t .. 1/? Could not obtain new session: unknown error: Chrome failed to start: crashed.
  (chrome not reachable)
  (The process started from chrome location /usr/lib64/chromium/chrome is no longer running, so ChromeDriver is assuming that Chrome has crashed.)
  (Driver info: chromedriver=94.0.4606.71 (1d32b169326531e600d836bd395efc1b53d0f6ef-refs/branch-heads/4606@{#1256}),platform=Linux 4.15.0-1110-aws x86_64) at /home/squamata/project/t/lib/OpenQA/SeleniumTest.pm line 98.
[18:23:14] t/full-stack.t .. 2/? # Tests were run but no plan was declared and done_testing() was not seen.
[18:23:14] t/full-stack.t ..      Dubious, test returned 254 (wstat 65024, 0xfe00)
All 2 subtests passed
[18:44:10] t/ui/23-audit-log.t ........................ Could not obtain new session: unknown error: Chrome failed to start: crashed.
  (chrome not reachable)
  (The process started from chrome location /usr/lib64/chromium/chrome is no longer running, so ChromeDriver is assuming that Chrome has crashed.)
  (Driver info: chromedriver=94.0.4606.71 (1d32b169326531e600d836bd395efc1b53d0f6ef-refs/branch-heads/4606@{#1256}),platform=Linux 4.15.0-1110-aws x86_64) at /home/squamata/project/t/ui/../lib/OpenQA/SeleniumTest.pm line 98.

(e.g. https://github.com/os-autoinst/openQA/pull/4288, https://github.com/os-autoinst/openQA/pull/4289, https://github.com/os-autoinst/openQA/pull/4290)

History

#1 Updated by mkittler about 2 months ago

  • Priority changed from Normal to Urgent

#2 Updated by mkittler about 2 months ago

  • Description updated (diff)

PR to downgrade as a short-term workaround: https://github.com/os-autoinst/openQA/pull/4291


By the way, it looks like version 94.0.4606.81-1606.1 which is currently in TW is not affected.

#3 Updated by okurz about 2 months ago

  • Target version set to Ready

#4 Updated by mkittler about 2 months ago

  • Status changed from In Progress to Feedback
  • The PR has been merged and should serve as a workaround for now.
  • I've been creating https://bugzilla.opensuse.org/show_bug.cgi?id=1191560 with a minimal script to reproduce the issue.
  • This is likely fixed with the next version considering it already works under TW. We will see this when a new version hits Leap 15.3 because the PR is not downgrading unconditionally.

#5 Updated by okurz about 2 months ago

  • Due date set to 2022-01-31
  • Priority changed from Urgent to Normal

The bug has been closed as duplicate of https://bugzilla.opensuse.org/show_bug.cgi?id=1191429 . With your workaround in place we can reduce priority and wait some time before revisiting.

#6 Updated by mkittler about 2 months ago

I just wanted to comment about it. I'm wondering how the apparently totally broken chromium package made its way into the distribution. At least we now know that the next update will very likely fix the issue.

#7 Updated by okurz about 2 months ago

mkittler wrote:

I'm wondering how the apparently totally broken chromium package made its way into the distribution

feel welcome to investigate and interview people how it could have come to that. Maybe that's even something we could improve from openQA side

#8 Updated by mkittler about 2 months ago

It looks like the problem wasn't visible in the openQA test: https://openqa.opensuse.org/tests/1963472#step/chromium/19
So apparently it doesn't always/immediately crash.

#9 Updated by okurz about 1 month ago

  • Priority changed from Normal to Low

#10 Updated by mkittler about 1 month ago

The bug has been marked as fixed so I'll try removing the workaround: https://github.com/os-autoinst/openQA/pull/4345

#11 Updated by mkittler about 1 month ago

  • Status changed from Feedback to Resolved

The PR has been merged by mergify so we're good again.

Also available in: Atom PDF