Project

General

Profile

action #73162

Updated by okurz 12 months ago

## Observation

```
[ 1108s] # Failed test 'test would have failed'
[ 1108s] # at ./t/01-test-utilities.t line 47.
[ 1108s]
[ 1108s] # Failed test 'manual termination via stop_service does not trigger _fail_and_exit'
[ 1108s] # at ./t/01-test-utilities.t line 58.
[ 1108s] # got: '1'
[ 1108s] # expected: '0'
[ 1108s] # Looks like you failed 2 tests of 5.
[ 1108s]
[ 1108s] # Failed test 'warnings in sub processes are fatal test failures'
[ 1108s] # at ./t/01-test-utilities.t line 59.
[ 1108s] # Looks like you failed 1 test of 1.
[ 1108s] ./t/01-test-utilities.t .....................................
[ 1108s] # Subtest: warnings in sub processes are fatal test failures
[ 1108s] # PID of test-process: 5808
[ 1108s] ok 1 - warning logged
[ 1108s] not ok 2 - test would have failed
[ 1108s] # PID of test-process: 5813
[ 1108s] ok 3 - message of test failure
[ 1108s] ok 4 - exit code of test failure is non-zero
[ 1108s] not ok 5 - manual termination via stop_service does not trigger _fail_and_exit
[ 1108s] 1..5
[ 1108s] not ok 1 - warnings in sub processes are fatal test failures
```

in https://build.opensuse.org/build/devel:openQA:TestGithub:PR-3456/openSUSE_Factory/x86_64/openQA/_log from https://github.com/os-autoinst/openQA/pull/3456

Checking reproducibility…

EDIT: happened again, e.g. in https://build.opensuse.org/package/live_build_log/devel:openQA/openQA/openSUSE_Factory/x86_64 even though at time of writing it was fine again

## Acceptance criteria
* **AC1:** t/01-test-utilities.t does not fail in OBS checks reproducibly (either fixed or excluded)

## Suggestions

* Wait until this happens again and take a look in the log for details
* Try to reproduce failure in test OBS project
* Fix or exclude

Back