Project

General

Profile

tickets #95242

Mailman - the 'archive' runner crashed.

Added by dstolte@arcor.de about 1 year ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Mailing lists
Target version:
-
Start date:
2021-07-08
Due date:
% Done:

100%

Estimated time:

Description

Hello Admins!

It seems that there are no updates of the mailing list web archives since 5th of july
(e.g. https://lists.opensuse.org/archives/list/updates@lists.opensuse.org/).

https://status.opensuse.org/ says mailing lists are operational but i guess that means
mail only, e.g. without the web archives.

Is anyone working on this? When can we expect a working web interface of the mail archives?

Best regards.

Dieter Stolte


Related issues

Related to openSUSE admin - tickets #112928: mailman3 - when a runner dies, why isn't it just restarted?New2022-06-23

History

#1 Updated by pjessen about 1 year ago

  • Category set to Mailing lists
  • Private changed from Yes to No

Issue confirmed.

#2 Updated by pjessen about 1 year ago

It looks like the 'archive' runner crashed, I found this in the log:

Jul 05 00:11:33 2021 (9522) HyperKitty failure on http://localhost/archives/api/mailman/archive: <html>
<head><title>413 Request Entity Too Large</title></head>
<body>
<center><h1>413 Request Entity Too Large</h1></center>
<hr><center>nginx/1.16.1</center>
</body>
</html>
 (413)
Jul 05 00:11:33 2021 (9522) Exception in the HyperKitty archiver: <html>
<head><title>413 Request Entity Too Large</title></head>
<body>
<center><h1>413 Request Entity Too Large</h1></center>
<hr><center>nginx/1.16.1</center>
</body>
</html>
Jul 05 00:11:33 2021 (9522) Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/mailman_hyperkitty/__init__.py", line 154, in _archive_message
    url = self._send_message(mlist, msg)
  File "/usr/lib/python3.6/site-packages/mailman_hyperkitty/__init__.py", line 210, in _send_message
    raise ValueError(result.text)
ValueError: <html>
<head><title>413 Request Entity Too Large</title></head>
<body>
<center><h1>413 Request Entity Too Large</h1></center>
<hr><center>nginx/1.16.1</center>
</body>
</html>

I restarted mailman - not sure if it has helped yet.

#3 Updated by pjessen about 1 year ago

I restarted mailman - not sure if it has helped yet.

It looks like it is recovering, slowly.

#4 Updated by pjessen about 1 year ago

  • Status changed from New to Workable
  • % Done changed from 0 to 50

Restarting mailman did get rid of the symptoms, but not the problem. The archive is working again, but why the 'archive' runner crashed and was not automatically restarted, who knows.

#5 Updated by pjessen about 1 year ago

  • Subject changed from mailing list web archives down to Mailman - the 'archive' runner crashed.
  • % Done changed from 50 to 0

#6 Updated by pjessen 5 months ago

  • Status changed from Workable to Resolved
  • Assignee set to pjessen
  • % Done changed from 0 to 100

Closing this one, nothing to do.

#7 Updated by pjessen about 2 months ago

  • Related to tickets #112928: mailman3 - when a runner dies, why isn't it just restarted? added

Also available in: Atom PDF