Project

General

Profile

action #90776

[timeboxed:16h] libyui REST API cannot be accessed on powerVM

Added by riafarov 7 months ago. Updated 6 months ago.

Status:
Closed
Priority:
High
Assignee:
Target version:
SUSE QA - SLE 15 SP3
Start date:
2021-04-07
Due date:
% Done:

0%

Estimated time:

Description

Observation

Somehow connection to SUT fails, might be some changes in the firewall configuration, as ip and port are correct.
Might be also server name is resolved to different ip address, but at least locally DNS resolves it properly.

openQA test in scenario sle-15-SP3-Online-ppc64le-textmode@ppc64le-hmc fails in
bootloader_start

Test suite description

Maintainer: okurz

Installation in textmode and selecting the textmode "desktop" during installation.

Reproducible

Fails since (at least) Build 171.1

Expected result

Last good: 162.7 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by riafarov 7 months ago

  • Project changed from openQA Tests to qe-yast
  • Category deleted (Bugs in existing tests)

#2 Updated by riafarov 6 months ago

  • Subject changed from libyui REST API cannot be accessed on powerVM to [timeboxed:16h] libyui REST API cannot be accessed on powerVM
  • Status changed from New to Workable

#3 Updated by riafarov 6 months ago

  • Status changed from Workable to In Progress
  • Assignee set to riafarov

#4 Updated by riafarov 6 months ago

The problem is that bootloader params are not passed to the installer, as we use ssh in textmode. It would not work for any ssh installation either. Solution is easy, just to set those env variables before execution of the yast.ssh command. Worked here: https://openqa.suse.de/tests/5887330#details

To make it more clean solution, I will move those actions to our setup_libyui test module to have all of these pieces in the single place.

#5 Updated by riafarov 6 months ago

Issue on zkvm (#91136) will be fixed in the scope of this ticket.

#6 Updated by riafarov 6 months ago

  • Status changed from In Progress to Feedback

#8 Updated by riafarov 6 months ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF