Project

General

Profile

action #90483

Ensure openQA packages in Leap are updated

Added by okurz 4 months ago. Updated 3 months ago.

Status:
Workable
Priority:
Normal
Assignee:
-
Category:
Feature requests
Target version:
Start date:
2021-03-29
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Motivation

openQA packages in openSUSE Leap are outdated by now. Leap 15.3 has switched to use SLE binaries + openSUSE Backports. We should ensure to have updated packages available in Leap. I did an initial update submission for both os-autoinst and openQA in https://build.opensuse.org/request/show/852949 and https://build.opensuse.org/request/show/881835 . The current problem is

[   38s] error: File not found: /home/abuild/rpmbuild/BUILDROOT/openQA-4.6.1616233122.00db033-bp153.3.1.x86_64/usr/lib/systemd/system/openqa-auto-update.*

likely due to https://github.com/os-autoinst/openQA/blob/master/dist/rpm/openQA.spec#L324

Acceptance criteria

  • AC1: openSUSE Leap 15.3 or more recent have a recent os-autoinst and openQA in official repos

Suggestions

  • Reproduce the build problem locally with osc build and fix it

History

#1 Updated by okurz 4 months ago

  • Target version changed from Ready to future

#2 Updated by osukup 3 months ago

https://github.com/os-autoinst/openQA/blob/master/dist/rpm/openQA.spec#L324 shudln't be problem is_opensuse macro is defined for Leap 15.3

#3 Updated by okurz 3 months ago

hm, ok. I just checked the recent build results in https://build.opensuse.org/package/live_build_log/openSUSE:Backports:SLE-15-SP3:Staging:adi:35/openQA/standard/x86_64 which are from Apr 16, last Friday, and the build still fails the same though.

Also available in: Atom PDF