Project

General

Profile

action #81150

sporadic fail of os-autoins t/10-virtio_terminal.t

Added by okurz 7 months ago. Updated 7 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Concrete Bugs
Target version:
Start date:
2020-12-17
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

Observed in https://github.com/os-autoinst/os-autoinst/pull/1606 and previously in another PR unrelated to t/10-virtio_terminal.t

Steps to reproduce

Using https://github.com/okurz/scripts/tree/master/count_fail_ratio

env runs=4000 count_fail_ratio prove -I. t/10-virtio_terminal.t

Problem

The "Steps to reproduce" show 4/4000 fails for okurz, showing

t/10-virtio_terminal.t .. Bailout called.  Further testing stopped:  test exceeds runtime limit of '10' seconds
Timeout for pipe other side helper at t/10-virtio_terminal.t line 33.
FAILED--Further testing stopped: test exceeds runtime limit of '10' seconds

so a fail rate of only 0.1%. Likely depending on timing behaviour this can happen more often, e.g. in GHA or when running with coverage analysis enabled.

Line 33 is an internal alarm handler. Because we try to use an alarm handler for the overall test module timeout here as well this might cause conflicts.

History

#1 Updated by okurz 7 months ago

  • Description updated (diff)

Trying to disable OpenQA::Test::TimeLimit

#2 Updated by okurz 7 months ago

  • Status changed from In Progress to Feedback

#3 Updated by okurz 7 months ago

  • Status changed from Feedback to Resolved

merged. This should suffice

Also available in: Atom PDF