Project

General

Profile

action #81050

[SLE][Migration][sle15sp3][Milestone]test fails in grub_test_snapshot - wait grub timeout

Added by coolgw 12 months ago. Updated 11 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2020-12-15
Due date:
% Done:

0%

Estimated time:
16.00 h
Difficulty:

Description

Observation

openQA test in scenario sle-15-SP3-Migration-from-SLE15-SPx-Milestone-x86_64-offline_sles15ga_ltss_scc_basesys-srv-desk-we-py2_def_full@64bit fails in
grub_test_snapshot

Test suite description

Reproducible

Fails since (at least) Build 100.1

Expected result

Last good: 89.1 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by coolgw 12 months ago

retry it:
barry:~/:[0]# /usr/share/openqa/script/clone_job.pl --within-instance http://openqa.suse.de 5170354 _GROUP=0
Created job #5199756: sle-15-SP3-Migration-from-SLE15-SPx-Milestone-x86_64-Build100.1-offline_sles15ga_ltss_scc_basesys-srv-desk-we-py2_def_full@64bit -> http://openqa.suse.de/t5199756
barry:~/:[0]# /usr/share/openqa/script/clone_job.pl --within-instance http://openqa.suse.de 5170354 _GROUP=0
Created job #5199757: sle-15-SP3-Migration-from-SLE15-SPx-Milestone-x86_64-Build100.1-offline_sles15ga_ltss_scc_basesys-srv-desk-we-py2_def_full@64bit -> http://openqa.suse.de/t5199757
barry:~/:[0]#

#2 Updated by coolgw 12 months ago

after rerun the issue is gone, but base on log the match time already reach 185s, so i think current timeout 200s is not enough now.
[2020-12-21T04:52:04.940 CET] [debug] <<< testapi::type_string(string="reboot\n", max_interval=250, wait_screen_changes=0, wait_still_screen=0, timeout=30, similarity_level=47)
[2020-12-21T04:52:05.184 CET] [debug] tests/boot/grub_test_snapshot.pm:30 called opensusebasetest::wait_grub -> lib/opensusebasetest.pm:655 called testapi::assert_screen
[2020-12-21T04:52:05.184 CET] [debug] <<< testapi::assert_screen(mustmatch=[
"grub2",
"inst-bootmenu"
], timeout=200)
[2020-12-21T04:52:06.865 CET] [debug] WARNING: check_asserted_screen took 1.05 seconds for 67 candidate needles - make your needles more specific
[2020-12-21T04:52:06.865 CET] [debug] no match: 199.3s, best candidate: boot_to_desktop-opensuse-20201103 (0.00)
[2020-12-21T04:52:07.468 CET] [debug] WARNING: check_asserted_screen took 0.59 seconds for 67 candidate needles - make your needles more specific
[2020-12-21T04:52:07.468 CET] [debug] no match: 198.3s, best candidate: boot_to_desktop-opensuse-20201103 (0.00)
[2020-12-21T04:52:07.867 CET] [debug] no change: 197.3s
[2020-12-21T04:52:09.301 CET] [debug] no match: 196.3s, best candidate: boot_to_desktop-opensuse-20201103 (0.00)
[2020-12-21T04:52:15.122 CET] [debug] WARNING: check_asserted_screen took 5.25 seconds for 67 candidate needles - make your needles more specific
[2020-12-21T04:52:15.123 CET] [debug] no match: 195.3s, best candidate: zypper_migration-leap-sles-grub2-20200911 (0.34)
[2020-12-21T04:52:20.095 CET] [debug] WARNING: check_asserted_screen took 4.96 seconds for 67 candidate needles - make your needles more specific
[2020-12-21T04:52:20.096 CET] [debug] no match: 190.0s, best candidate: zypper_migration-leap-sles-grub2-20200911 (0.34)
[2020-12-21T04:52:24.458 CET] [debug] WARNING: check_asserted_screen took 4.35 seconds for 67 candidate needles - make your needles more specific
[2020-12-21T04:52:24.458 CET] [debug] no match: 185.0s, best candidate: zypper_migration-leap-sles-grub2-20200911 (0.34)
[2020-12-21T04:52:28.836 CET] [debug] >>> testapi::_handle_found_needle: found bootmenu-sles15-20201109, similarity 1.00 @ 0/0

#4 Updated by coolgw 11 months ago

  • Status changed from New to Resolved

#5 Updated by okurz 11 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: offline_sles15ga_ltss_scc_basesys-srv-desk-we-py2_def_full
https://openqa.suse.de/tests/5170354

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

Also available in: Atom PDF