Project

General

Profile

action #80826

coordination #39719: [saga][epic] Detection of "known failures" for stable tests, easy test results review and easy tracking of known issues

coordination #80828: [epic] Trigger 'auto-review' and 'openqa-investigate' from within openQA when jobs incomplete or fail on o3+osd

Trigger 'auto-review' from within openQA when jobs incomplete on osd as well

Added by okurz 6 months ago. Updated 6 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Feature requests
Target version:
Start date:
2020-12-08
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Motivation

Same as in #80736 for o3 we should run auto-review from within openQA on osd for incompletes

Acceptance criteria

  • AC1: auto-review is triggered on osd when jobs incomplete

Suggestions

  • wait for hook support to be deployed to osd and enable there as well for incomplete
  • monitor impact on osd

Related issues

Copied from openQA Project - action #80736: Trigger 'auto-review' from within openQA when jobs incomplete (or fail) , for testing: auto_review:"tests died: unable to load main.pm, check the log for the cause"Resolved

History

#1 Updated by okurz 6 months ago

  • Copied from action #80736: Trigger 'auto-review' from within openQA when jobs incomplete (or fail) , for testing: auto_review:"tests died: unable to load main.pm, check the log for the cause" added

#2 Updated by okurz 6 months ago

  • Parent task changed from #39719 to #80828

#3 Updated by okurz 6 months ago

  • Status changed from Feedback to In Progress

new changes have been deployed on osd. We can now bring the scripts onto osd:

https://gitlab.suse.de/openqa/salt-states-openqa/-/merge_requests/416 , merged.

I have observed on osd that /etc/openqa/openqa.ini has not been updated from /etc/openqa/openqa.ini.rpmnew for a long time. Did that now with vimdiff /etc/openqa/openqa.ini{,.rpmnew}. Then enabled

job_done_hook_failed = env host=openqa.suse.de /opt/os-autoinst-scripts/openqa-label-known-issues-hook
job_done_hook_incomplete = env host=openqa.suse.de /opt/os-autoinst-scripts/openqa-label-known-issues-hook

have created WIP-MR https://gitlab.suse.de/openqa/salt-states-openqa/-/merge_requests/417 to make that persistent. WIP until I have it confirmed on OSD. Called systemctl restart openqa-webui openqa-gru and will monitor logs:

journalctl -f -u openqa-webui -u openqa-gru
tail -f /var/log/openqa_gru

I have seen first "failed" jobs to trigger the hooks already, e.g. https://openqa.suse.de/tests/5156025 as "unknown issue".

I have added the failed hook config to https://gitlab.suse.de/openqa/salt-states-openqa/-/merge_requests/417 as well

#4 Updated by okurz 6 months ago

  • Status changed from In Progress to Resolved

MR merged and deployed. auto-review active for incomplete+failed on osd as well

Also available in: Atom PDF